summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin MacMartin2015-07-03 16:17:22 -0400
committerKevin MacMartin2015-07-03 16:17:22 -0400
commit5852757410d7fda96a54ea0f525738d82cf188ff (patch)
treea77fedc210d53fcc19731dd4e9289d5d2f192d21
parent2e461895ca44353dd9fb8f3d396eba0fee669bc2 (diff)
downloadaur-5852757410d7fda96a54ea0f525738d82cf188ff.tar.gz
Update to 06232015 and add a .gitignore
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD35
-rw-r--r--wizorb.desktop12
3 files changed, 31 insertions, 20 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..15a54342d157
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.pkg.tar.xz
+pkg
+src
+wizorb-06232015-bin
diff --git a/PKGBUILD b/PKGBUILD
index ee5019c4f015..014e06863f95 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,26 +3,35 @@
_pkgname=wizorb
pkgname=$_pkgname-hib
-pkgver=1.1
-pkgrel=4
+pkgver=06232015
+pkgrel=1
pkgdesc='A retro-RPG themed breakout style game (Humble Bundle version)'
url='http://www.wizorb.com'
license=('custom:commercial')
-depends=('mono' 'openal')
+depends=('glibc')
arch=('i686' 'x86_64')
options=('!strip' '!upx')
-source=("$_pkgname.sh" "$_pkgname.desktop")
-sha512sums=('7ab7d83b7c99eafaee614832efa30b4f399eb0c62c47791ec9b3169eafe1195d4fdc9283c54190cf8aee916ec046b2557297d3c5000e732566ddf0f2efd8c8bb'
- '654dec6278d19d25440e74e7c850f3ab6f06c9af5ad39a7bf7dd8179234e1a3e763364e84aae7daab118db6b1a11d590bbe2621ff05fc7be40069f94bb97f331')
-source_i686+=("hib://$_pkgname-32bit.tar.gz")
-source_x86_64+=("hib://$_pkgname-64bit.tar.gz")
-sha512sums_i686+=('b5997e9575c7339667c756d62893d0f20e264ca2cfda6383a3fa4a9ba2a40bfaaf943db5ebff4e73ae7f21624a83e3cfe7f7557b349e7b502282d00cf6959b91')
-sha512sums_x86_64+=('c2ac71e97361e5b2eeaf547987a6de56df4663caf5b6d510b2db5a881ba5873ecb9ad4ba40c3dd8b91eebde5af5da60cdf16141c62fe009f0f43a88f15af7a05')
+source=(
+ "$_pkgname-06232015-bin"
+ "$_pkgname.desktop"
+)
+sha512sums=(
+ '556ec725522545ab5b99ef2f21a4e4572b50537ddf551e340801874db3fff8fc042362b511de779c8e6425a6c079de31788e03b01766aba5485b900cc34086ea'
+ 'd5d30b3c9e39de446a4d5be9781c4001557b1b66e96fa85331fbc8cc5b58ecea82c18c734b6fed97d2fdd78798d473c759a05d1f986c2b81deb49b5cec2e4ffb'
+)
package() {
- install -d "$pkgdir/opt"
- cp -r $_pkgname "$pkgdir/opt/"
- install -Dm755 $_pkgname.sh "$pkgdir/usr/bin/$_pkgname"
+ install -d "$pkgdir/opt/$_pkgname"
+ for dir in ./*; do
+ [[ -d "$dir" ]] \
+ && cp -r --no-preserve=ownership "$dir" "$pkgdir/opt/$_pkgname/"
+ done
install -Dm644 $_pkgname.desktop "$pkgdir/usr/share/applications/$_pkgname.desktop"
+ install -dm755 "$pkgdir/usr/bin"
+ printf '%s\n\n%s\n%s\n' \
+ '#!/usr/bin/env bash' \
+ 'cd /opt/wizorb/data' \
+ './Wizorb' > "$pkgdir/usr/bin/$_pkgname"
+ chmod 755 "$pkgdir/usr/bin/$_pkgname"
}
diff --git a/wizorb.desktop b/wizorb.desktop
index 465c087ec160..ccd336097476 100644
--- a/wizorb.desktop
+++ b/wizorb.desktop
@@ -1,12 +1,10 @@
[Desktop Entry]
Version=1.0
Type=Application
-Icon=/opt/wizorb/wizorb.png
-Exec=wizorb
+Name=Wizorb
+Comment=Block-breaking game set in a fantasy world
+Icon=/opt/wizorb/data/Wizorb.bmp
+Exec=/usr/bin/wizorb
Terminal=false
StartupNotify=false
-
-Name=Wizorb
-Comment=An all-new block-breaking game set in a fantasy world.
-
-Categories=Game;ArcadeGame;
+Categories=Game;