summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEvangelos Foutras2022-11-17 21:55:26 +0200
committerEvangelos Foutras2022-11-17 21:55:26 +0200
commite91d2a421b8ee4fb20461025a258dd775270001f (patch)
tree16cd072162fd32ea3b0173b4198386bb686ddcd2
downloadaur-wkhtmltopdf.tar.gz
Move from [community] due to QtWebKit removal
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD35
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e12dbd53269b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = wkhtmltopdf
+ pkgdesc = Command line tools to render HTML into PDF and various image formats
+ pkgver = 0.12.6
+ pkgrel = 1
+ url = https://wkhtmltopdf.org/
+ arch = x86_64
+ license = LGPL3
+ makedepends = git
+ depends = qt5-webkit
+ depends = qt5-svg
+ depends = qt5-xmlpatterns
+ optdepends = xorg-server: wkhtmltopdf needs X or Xvfb to operate
+ source = git+https://github.com/wkhtmltopdf/wkhtmltopdf.git#tag=0.12.6?signed
+ validpgpkeys = 76C0969C076A23EC4849F462D3E3E8ACF99DE8EA
+ sha256sums = SKIP
+
+pkgname = wkhtmltopdf
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9a9a38a2c9ae
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer:
+
+pkgname=wkhtmltopdf
+pkgver=0.12.6
+pkgrel=1
+pkgdesc="Command line tools to render HTML into PDF and various image formats"
+arch=('x86_64')
+url="https://wkhtmltopdf.org/"
+license=('LGPL3')
+depends=('qt5-webkit' 'qt5-svg' 'qt5-xmlpatterns')
+makedepends=('git')
+optdepends=('xorg-server: wkhtmltopdf needs X or Xvfb to operate')
+source=("git+https://github.com/wkhtmltopdf/wkhtmltopdf.git#tag=$pkgver?signed")
+sha256sums=('SKIP')
+validpgpkeys=('76C0969C076A23EC4849F462D3E3E8ACF99DE8EA') # Ashish Kulkarni (Open Source) <ashish@kulkarni.dev>
+
+build() {
+ cd $pkgname
+ qmake-qt5 wkhtmltopdf.pro
+ make
+}
+
+package() {
+ cd $pkgname
+ make INSTALL_ROOT="$pkgdir/usr" install
+
+ # Generate and install man pages
+ install -d "$pkgdir/usr/share/man/man1"
+ LD_LIBRARY_PATH=bin ./bin/wkhtmltopdf --manpage \
+ >"$pkgdir/usr/share/man/man1/wkhtmltopdf.1"
+ LD_LIBRARY_PATH=bin ./bin/wkhtmltoimage --manpage \
+ >"$pkgdir/usr/share/man/man1/wkhtmltoimage.1"
+}
+
+# vim:set ts=2 sw=2 et: