summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatt Coffin2021-03-24 12:27:31 -0600
committerMatt Coffin2021-03-24 12:27:31 -0600
commitae6be6ce42a6f0f6002785c03fce3a2fbe9c32c8 (patch)
treef84824ce249cd4e9d3d4c0c9b8b8d85c4b0a380d
parentb8c62f0f19b60b20f4d4fed95992f9a26da485a1 (diff)
downloadaur-ae6be6ce42a6f0f6002785c03fce3a2fbe9c32c8.tar.gz
version: 0.4.1-2
Removed some weird files being left in /usr by cargo install
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6b75fa834df3..90116c49df9d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = wl-clipboard-rs
pkgdesc = A safe Rust reimplementation of the Wayland command-line copy/paste utilities
pkgver = 0.4.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/YaLTeR/wl-clipboard-rs
arch = x86_64
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index 0e1d1639366a..f75b57bd4d96 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
# Maintainer: Matt Coffin <mcoffin13 at gmail.com>
pkgname=wl-clipboard-rs
pkgver=0.4.1
-pkgrel=1
+pkgrel=2
epoch=
pkgdesc="A safe Rust reimplementation of the Wayland command-line copy/paste utilities"
arch=('x86_64')
@@ -35,6 +35,11 @@ package() {
fi
cargo install --path "$pkgname-$pkgver" --root "$pkgdir/usr" --bins
+ local _f
+ for _f in "$pkgdir"/usr/{.crates.toml,.crates2.json}; do
+ [ ! -e "$_f" ] || rm "$_f"
+ done
+
cd "$pkgname-$pkgver"
install -Dm644 "README.md" "$pkgdir/usr/share/doc/$pkgname/README.md"