summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorClément Martinez2025-04-03 19:29:52 +0100
committerClément Martinez2025-04-03 19:29:52 +0100
commita05d6df58c453fa22d8b7d1f5313cba57772f5fd (patch)
treeb9b61bd7bc9bf1298e5a70f3055cb239767d540d
parentb7a90dde64e0119900723efcaed49b840100ca0b (diff)
downloadaur-a05d6df58c453fa22d8b7d1f5313cba57772f5fd.tar.gz
v0.3.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 323e0797e231..0fa0b3c5d7b2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = wl-kbptr
pkgdesc = Control the mouse pointer with the keyboard on Wayland
- pkgver = 0.2.3
+ pkgver = 0.3.0
pkgrel = 1
url = https://github.com/moverest/wl-kbptr
arch = x86_64
@@ -10,7 +10,9 @@ pkgbase = wl-kbptr
depends = cairo
depends = wayland
depends = libxkbcommon
- source = https://github.com/moverest/wl-kbptr/archive/refs/tags/v0.2.3.tar.gz
- sha256sums = 0d03f83d94b6acfdb07f3ee3760c1abc207eef5a8346af38978d6bcb46ac58b8
+ depends = opencv
+ depends = pixman
+ source = https://github.com/moverest/wl-kbptr/archive/refs/tags/v0.3.0.tar.gz
+ sha256sums = 69775029acb8ff7d814a2868afe22e72b8c9c99cbb35b0acf57eccd3609b089c
pkgname = wl-kbptr
diff --git a/PKGBUILD b/PKGBUILD
index 266bcba2fc2c..ab536f54af1e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,18 @@
# Maintainer: Clément Martinez <me at moverest dot xyz>
pkgname=wl-kbptr
-pkgver=0.2.3
-pkgrel=1
+pkgver=0.3.0
+pkgrel=0
url="https://github.com/moverest/wl-kbptr"
pkgdesc="Control the mouse pointer with the keyboard on Wayland"
arch=('x86_64')
license=('GPL-3.0')
-depends=('cairo' 'wayland' 'libxkbcommon')
+depends=('cairo' 'wayland' 'libxkbcommon' 'opencv' 'pixman')
makedepends=('meson' 'wayland-protocols')
source=("https://github.com/moverest/wl-kbptr/archive/refs/tags/v$pkgver.tar.gz")
-sha256sums=('0d03f83d94b6acfdb07f3ee3760c1abc207eef5a8346af38978d6bcb46ac58b8')
+sha256sums=('69775029acb8ff7d814a2868afe22e72b8c9c99cbb35b0acf57eccd3609b089c')
build() {
- arch-meson "$pkgname-$pkgver" build
+ arch-meson "$pkgname-$pkgver" build -Dopencv=enabled
ninja -C build
}