summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRuben De Smet2017-03-25 17:46:46 +0100
committerRuben De Smet2017-03-25 17:46:46 +0100
commit4c43ee4903538b597598a990183d53dc252dac5c (patch)
treea568b7794f96de756fc3a17685463bc27bc0612d
downloadaur-4c43ee4903538b597598a990183d53dc252dac5c.tar.gz
Initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD42
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ba347eade707
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by mksrcinfo v8
+# Sat Mar 25 16:46:39 UTC 2017
+pkgbase = orbment-wall-git
+ pkgdesc = Orbment plugins for Wayland Wall protocols
+ pkgver = r33.8bb4672
+ pkgrel = 1
+ url = https://github.com/wayland-wall/orbment-wall
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ depends = wayland-wall
+ depends = wayland-protocols
+ depends = orbment
+ provides = orbment-wall
+ provides = orbment-wall-git
+ conflicts = orbment-wall
+ source = git+https://github.com/wayland-wall/orbment-wall.git#branch=wip/injector
+ md5sums = SKIP
+
+pkgname = orbment-wall-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6ba43f51a2ab
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Ruben De Smet <me at rubdos dot be>
+
+pkgname=orbment-wall-git
+_gitname=orbment-wall
+pkgver=r33.8bb4672
+pkgrel=1
+pkgdesc="Orbment plugins for Wayland Wall protocols"
+arch=('i686' 'x86_64')
+url="https://github.com/wayland-wall/orbment-wall"
+license=('MIT')
+depends=('wayland-wall' 'wayland-protocols' 'orbment')
+makedepends=('git')
+provides=('orbment-wall' 'orbment-wall-git')
+conflicts=('orbment-wall')
+source=("git+https://github.com/wayland-wall/orbment-wall.git#branch=wip/injector")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_gitname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$srcdir/$_gitname"
+ git submodule update --init
+ autoreconf --install
+
+ ./configure \
+ --prefix=/usr
+}
+
+build() {
+ cd "$srcdir/$_gitname"
+ make
+}
+
+package() {
+ cd "$srcdir/$_gitname"
+ make install install-man DESTDIR="$pkgdir"
+
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/orbment-wall-git/COPYING"
+}