summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorthyTwilightGoth2023-06-11 22:43:38 -0700
committerthyTwilightGoth2023-06-11 22:43:38 -0700
commit15016f68ab15c5dcf9438dd283010040c588a08c (patch)
tree9850692bbb9da862baeb5de5ba3bd2e121153579
parentb408c800cb6d6be1d1a1c980c7a3d6c1703e1b3c (diff)
downloadaur-wlcs.tar.gz
Update to latest version and move back to non VCS System
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD19
2 files changed, 15 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fc5158f42f47..48090ce4d0d4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = wlcs
pkgdesc = Canonical's protocol-conformance-verifying test suite for Wayland compositor implementations.
- pkgver = 1.3.0
- pkgrel = 2
+ pkgver = 1.5.0
+ pkgrel = 1
url = https://github.com/MirServer/wlcs
arch = x86_64
arch = i686
@@ -15,7 +15,7 @@ pkgbase = wlcs
depends = gtest
depends = boost-libs
depends = wayland
- source = git+https://github.com/MirServer/wlcs.git
- sha256sums = SKIP
+ source = wlcs-1.5.0.tar.gz::https://github.com/MirServer/wlcs/archive/v1.5.0.tar.gz
+ sha512sums = 2d05f62ccfbbd0c4300556e7713b086663678b2ee87fe8297cb7c81a482d23fa7948034da494f91609b954c11e350d4e52837217fbafeaba2a694de7828480b6
pkgname = wlcs
diff --git a/PKGBUILD b/PKGBUILD
index a86cd7790c6a..6d83a4d30e09 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,10 @@
# Maintainer: thyTwilightGoth <https://aur.archlinux.org/account/thyTwilightGoth>
# Contributor: Pedro <https://aur.archlinux.org/account/PedroHLC>
-pkgname=wlcs
-pkgver=1.3.0
-pkgrel=2
+_pkgname=wlcs
+pkgname=$_pkgname
+pkgver=1.5.0
+pkgrel=1
pkgdesc="Canonical's protocol-conformance-verifying test suite for Wayland compositor implementations."
url='https://github.com/MirServer/wlcs'
arch=(x86_64 i686 aarch64)
@@ -11,22 +12,24 @@ license=(GPL)
depends=(gtest boost-libs wayland)
makedepends=(git cmake boost gmock wayland-protocols)
optdepends=()
-source=("git+https://github.com/MirServer/wlcs.git")
-sha256sums=('SKIP')
+source=("$_pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
+sha512sums=('2d05f62ccfbbd0c4300556e7713b086663678b2ee87fe8297cb7c81a482d23fa7948034da494f91609b954c11e350d4e52837217fbafeaba2a694de7828480b6')
BUILD_DIR=build
build() {
- cd "${pkgname}"
+ cd "$pkgname-$pkgver"
mkdir -p "${BUILD_DIR}"
cd "${BUILD_DIR}"
cmake -DCMAKE_INSTALL_PREFIX:PATH=/usr -DCMAKE_INSTALL_LIBDIR="lib/" ..
- cmake --build ./
+ cmake --build ./ -j$(($(nproc) / 2))
+# cmake --build ./
}
package() {
- cd "${pkgname}/${BUILD_DIR}"
+ cd "$pkgname-$pkgver/${BUILD_DIR}"
make DESTDIR="${pkgdir}/" install
}
# vim:set ts=2 sw=2 et:
+# cmake --build ./ -j$(($(nproc) / 2))