summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFiregem2021-10-17 01:21:50 -0400
committerFiregem2021-10-17 01:21:50 -0400
commite7b1860843ccdd07e2eb55adabaac349504c0338 (patch)
treefa672d50f42b536e6880df2f995313493aa1ff28
downloadaur-e7b1860843ccdd07e2eb55adabaac349504c0338.tar.gz
init
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD29
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..56c646f64c76
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = wlopm-git
+ pkgdesc = Wayland output power management.
+ pkgver = r15.4ffa093
+ pkgrel = 1
+ url = https://git.sr.ht/~leon_plickat/wlopm
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ depends = wayland
+ depends = wayland-protocols
+ provides = wlopm
+ conflicts = wlopm
+ source = git+https://git.sr.ht/~leon_plickat/wlopm
+ md5sums = SKIP
+
+pkgname = wlopm-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..211df8bf1335
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Firegem <mrfiregem [at] protonmail [dot] ch>
+pkgname=wlopm-git
+pkgver=r15.4ffa093
+pkgrel=1
+pkgdesc="Wayland output power management."
+arch=('x86_64')
+url="https://git.sr.ht/~leon_plickat/wlopm"
+license=('GPL3')
+depends=(wayland{,-protocols})
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=('git+https://git.sr.ht/~leon_plickat/wlopm')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ make PREFIX='/usr' DESTDIR="$pkgdir"
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ make install PREFIX='/usr' DESTDIR="$pkgdir"
+}