summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsentriz2020-07-30 12:45:30 +0100
committersentriz2020-07-30 12:45:30 +0100
commit942ecfa7eacab6a69b130c085afd09937c05d930 (patch)
tree242467e72da2fdf168bba913f3c9a0f6f835ac3f
downloadaur-942ecfa7eacab6a69b130c085afd09937c05d930.tar.gz
init
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD42
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..586ca500f9e8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = wlr-sunclock-git
+ pkgdesc = Displays a sunclock desktop widget using the layer shell protocol
+ pkgver = r11.dc63ea9
+ pkgrel = 1
+ url = https://github.com/sentriz/wlr-sunclock
+ arch = x86_64
+ license = LGPL3
+ makedepends = git
+ makedepends = meson
+ makedepends = ninja
+ depends = gtk3
+ depends = gobject-introspection
+ depends = gtk-layer-shell
+ provides = wlr-sunclock
+ conflicts = wlr-sunclock
+ source = wlr-sunclock::git+https://github.com/sentriz/wlr-sunclock.git
+ md5sums = SKIP
+
+pkgname = wlr-sunclock-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d251861ac447
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Senan Kelly <senan@senan.xyz>
+
+pkgname=wlr-sunclock-git
+_pkgname=wlr-sunclock
+pkgver=r11.dc63ea9
+pkgrel=1
+pkgdesc='Displays a sunclock desktop widget using the layer shell protocol'
+arch=(x86_64)
+url='https://github.com/sentriz/wlr-sunclock'
+license=('LGPL3')
+groups=()
+depends=('gtk3' 'gobject-introspection' 'gtk-layer-shell')
+makedepends=('git' 'meson' 'ninja')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+replaces=()
+backup=()
+options=()
+install=
+source=('wlr-sunclock::git+https://github.com/sentriz/wlr-sunclock.git')
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$_pkgname"
+}
+
+build() {
+ cd "$_pkgname"
+ meson --prefix /usr "$srcdir/build"
+ ninja -C "$srcdir/build"
+}
+
+package() {
+ cd "$_pkgname"
+ DESTDIR="$pkgdir" ninja -C "$srcdir/build" install
+}