summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFerdinand Bachmann2023-12-04 01:30:21 +0100
committerFerdinand Bachmann2023-12-04 01:31:48 +0100
commit30f295866e1a72a2a158acba02934208718671e1 (patch)
tree0defb692e1f82a1e53b130ec2fdf9eb7bf1762a0
parente84dea3911b7e903b79c27f2389c20e78468af1e (diff)
parent36ace4f2f57349cb30f0ee7c64a0332487012c1c (diff)
downloadaur-30f295866e1a72a2a158acba02934208718671e1.tar.gz
merge upstream changes
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD9
2 files changed, 10 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0208f9c9584e..457c9fc40518 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = wlroots-asan-git
pkgdesc = Modular Wayland compositor library (git version, with address sanitizer)
- pkgver = 0.16.0.r5511.e59f4d4f
+ pkgver = 0.18.0.r6762.d3a339a0
pkgrel = 1
url = https://gitlab.freedesktop.org/wlroots/wlroots
arch = x86_64
@@ -12,6 +12,7 @@ pkgbase = wlroots-asan-git
makedepends = xorgproto
depends = glslang
depends = libinput
+ depends = libliftoff
depends = libxcb
depends = libxkbcommon
depends = opengl-driver
@@ -22,11 +23,11 @@ pkgbase = wlroots-asan-git
depends = xcb-util-wm
depends = seatd
depends = vulkan-icd-loader
- depends = vulkan-validation-layers
depends = xorg-xwayland
+ depends = libdisplay-info
provides = libwlroots.so
- provides = wlroots=0.16.0
- provides = wlroots-git=0.16.0.r5511.e59f4d4f
+ provides = wlroots=0.18.0
+ provides = wlroots-git=0.18.0.r6762.d3a339a0
conflicts = wlroots
options = debug
source = wlroots::git+https://gitlab.freedesktop.org/wlroots/wlroots.git
diff --git a/PKGBUILD b/PKGBUILD
index 1720eb2cf5b9..a9b6413a2880 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Antonin Décimo <antonin dot decimo at gmail dot com>
pkgname=wlroots-asan-git
_pkgname=wlroots
-pkgver=0.16.0.r5542.98c5f58a
+pkgver=0.18.0.r6762.d3a339a0
pkgrel=1
license=(custom:MIT)
pkgdesc='Modular Wayland compositor library (git version, with address sanitizer)'
@@ -14,6 +14,7 @@ options=(debug)
depends=(
glslang
libinput
+ libliftoff
libxcb
libxkbcommon
opengl-driver
@@ -24,8 +25,8 @@ depends=(
xcb-util-wm
seatd
vulkan-icd-loader
- vulkan-validation-layers
- xorg-xwayland)
+ xorg-xwayland
+ libdisplay-info)
makedepends=(
git
meson
@@ -66,7 +67,7 @@ build () {
}
package () {
- DESTDIR="${pkgdir}" meson install -C build
+ meson install -C "${_builddir}" --destdir="${pkgdir}"
install -Dm644 "${_pkgname}/"LICENSE "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
}