summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Perez de Castro2023-03-04 23:44:39 +0200
committerAdrian Perez de Castro2023-03-04 23:44:39 +0200
commit36ace4f2f57349cb30f0ee7c64a0332487012c1c (patch)
tree244b3d7f95cc54ddf9c6429c7cb12f57e25395a6
parent9915770484d00e1f06256308f900fe4204bd1b5e (diff)
downloadaur-36ace4f2f57349cb30f0ee7c64a0332487012c1c.tar.gz
Add liblifoff and libdisplay-info dependencies
While at it, use "meson install" in the package() function.
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7bca6fcee59a..883631f3b53e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = wlroots-git
pkgdesc = Modular Wayland compositor library (git version)
- pkgver = 0.16.0.r5511.e59f4d4f
+ pkgver = 0.17.0.r6161.3a200aa2
pkgrel = 1
url = https://gitlab.freedesktop.org/wlroots/wlroots
arch = x86_64
@@ -12,6 +12,7 @@ pkgbase = wlroots-git
makedepends = xorgproto
depends = glslang
depends = libinput
+ depends = libliftoff
depends = libxcb
depends = libxkbcommon
depends = opengl-driver
@@ -22,10 +23,10 @@ pkgbase = wlroots-git
depends = xcb-util-wm
depends = seatd
depends = vulkan-icd-loader
- depends = vulkan-validation-layers
depends = xorg-xwayland
+ depends = libdisplay-info
provides = libwlroots.so
- provides = wlroots=0.16.0
+ provides = wlroots=0.17.0
conflicts = wlroots
options = debug
source = wlroots-git::git+https://gitlab.freedesktop.org/wlroots/wlroots.git
diff --git a/PKGBUILD b/PKGBUILD
index 3076b9dc28fb..78db8bc60e62 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Adrian Perez de Castro <aperez@igalia.com>
# Maintainer: Antonin Décimo <antonin dot decimo at gmail dot com>
pkgname=wlroots-git
-pkgver=0.16.0.r5511.e59f4d4f
+pkgver=0.17.0.r6161.3a200aa2
pkgrel=1
license=(custom:MIT)
pkgdesc='Modular Wayland compositor library (git version)'
@@ -13,6 +13,7 @@ options=(debug)
depends=(
glslang
libinput
+ libliftoff
libxcb
libxkbcommon
opengl-driver
@@ -23,8 +24,8 @@ depends=(
xcb-util-wm
seatd
vulkan-icd-loader
- vulkan-validation-layers
- xorg-xwayland)
+ xorg-xwayland
+ libdisplay-info)
makedepends=(
git
meson
@@ -65,7 +66,7 @@ build () {
}
package () {
- DESTDIR="${pkgdir}" meson install -C build
+ meson install -C "${_builddir}" --destdir="${pkgdir}"
install -Dm644 "${pkgname}/"LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}