summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFerdinand Bachmann2024-01-28 12:40:16 +0100
committerFerdinand Bachmann2024-01-28 12:40:16 +0100
commit3daf433cabc00f862950c95defb187dcf107670e (patch)
tree3f3a3ebbf448072d1296af21fb6440f8483ffd20
parent30f295866e1a72a2a158acba02934208718671e1 (diff)
downloadaur-3daf433cabc00f862950c95defb187dcf107670e.tar.gz
merge upstream changes
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD58
2 files changed, 44 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 457c9fc40518..87896c5face0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,24 @@
pkgbase = wlroots-asan-git
- pkgdesc = Modular Wayland compositor library (git version, with address sanitizer)
- pkgver = 0.18.0.r6762.d3a339a0
+ pkgdesc = Modular Wayland compositor library (git development version, with address sanitizer)
+ pkgver = 0.18.0.r6859.4688a371
pkgrel = 1
url = https://gitlab.freedesktop.org/wlroots/wlroots
arch = x86_64
- license = custom:MIT
+ license = MIT
makedepends = git
makedepends = meson
makedepends = vulkan-headers
makedepends = wayland-protocols
makedepends = xorgproto
- depends = glslang
+ makedepends = xorg-xwayland
+ depends = glibc
+ depends = libdrm
depends = libinput
depends = libliftoff
depends = libxcb
+ depends = libglvnd
depends = libxkbcommon
+ depends = systemd-libs
depends = opengl-driver
depends = pixman
depends = wayland
@@ -22,15 +26,17 @@ pkgbase = wlroots-asan-git
depends = xcb-util-renderutil
depends = xcb-util-wm
depends = seatd
+ depends = glslang
depends = vulkan-icd-loader
- depends = xorg-xwayland
depends = libdisplay-info
+ optdepends = xorg-xwayland: enable X11 support
provides = libwlroots.so
provides = wlroots=0.18.0
- provides = wlroots-git=0.18.0.r6762.d3a339a0
+ provides = wlroots-git=0.18.0.r6859.4688a371
conflicts = wlroots
+ conflicts = wlroots-git
options = debug
- source = wlroots::git+https://gitlab.freedesktop.org/wlroots/wlroots.git
- md5sums = SKIP
+ source = wlroots-asan-git::git+https://gitlab.freedesktop.org/wlroots/wlroots.git
+ b2sums = SKIP
pkgname = wlroots-asan-git
diff --git a/PKGBUILD b/PKGBUILD
index a9b6413a2880..d0bb8687fcc0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,23 @@
# Maintainer: Adrian Perez de Castro <aperez@igalia.com>
+# Maintainer: GreyXor <greyxor@protonmail.com>
# Maintainer: Antonin Décimo <antonin dot decimo at gmail dot com>
pkgname=wlroots-asan-git
-_pkgname=wlroots
-pkgver=0.18.0.r6762.d3a339a0
+pkgver=0.18.0.r6859.4688a371
pkgrel=1
-license=(custom:MIT)
-pkgdesc='Modular Wayland compositor library (git version, with address sanitizer)'
-url=https://gitlab.freedesktop.org/wlroots/wlroots
+pkgdesc='Modular Wayland compositor library (git development version, with address sanitizer)'
arch=(x86_64)
-provides=("libwlroots.so" "wlroots=${pkgver%%.r*}" "wlroots-git=${pkgver}")
-conflicts=(wlroots)
+url=https://gitlab.freedesktop.org/wlroots/wlroots
+license=(MIT)
options=(debug)
depends=(
- glslang
+ glibc
+ libdrm
libinput
libliftoff
libxcb
+ libglvnd
libxkbcommon
+ systemd-libs
opengl-driver
pixman
wayland
@@ -24,54 +25,55 @@ depends=(
xcb-util-renderutil
xcb-util-wm
seatd
+ glslang
vulkan-icd-loader
- xorg-xwayland
libdisplay-info)
makedepends=(
git
meson
vulkan-headers
wayland-protocols
- xorgproto)
-source=("${_pkgname}::git+${url}.git")
-md5sums=('SKIP')
-
+ xorgproto
+ xorg-xwayland
+)
+optdepends=(
+ 'xorg-xwayland: enable X11 support'
+)
+provides=("libwlroots.so" "${pkgname%-asan-git}=${pkgver%%.r*}" "wlroots-git=${pkgver}")
+conflicts=("${pkgname%-asan-git}" "wlroots-git")
+source=("${pkgname}::git+${url}.git")
+b2sums=('SKIP')
_builddir="build"
_builddir_pkgver="build-pkgver"
-_meson_setup () {
+_meson_setup() {
CFLAGS="$CFLAGS -fsanitize=address,undefined" arch-meson \
--buildtype=debug \
-Dwerror=false \
-Dexamples=false \
- "${_pkgname}" "$1"
+ "${pkgname}" "$1"
}
-prepare () {
+prepare() {
_meson_setup "${_builddir_pkgver}"
}
-pkgver () {
+pkgver() {
(
set -o pipefail
- meson introspect --projectinfo "${_builddir_pkgver}" \
- | awk 'match($0, /"version":\s*"([[:digit:]]+\.[[:digit:]]+\.[[:digit:]]+)-dev"/, ret) {printf "%s",ret[1]}'
+ meson introspect --projectinfo "${_builddir_pkgver}" |
+ awk 'match($0, /"version":\s*"([[:digit:]]+\.[[:digit:]]+\.[[:digit:]]+)-dev"/, ret) {printf "%s",ret[1]}'
)
- cd "${_pkgname}"
+ cd "${pkgname}"
printf ".r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-build () {
+build() {
_meson_setup "${_builddir}"
meson compile -C "${_builddir}"
}
-package () {
+package() {
meson install -C "${_builddir}" --destdir="${pkgdir}"
- install -Dm644 "${_pkgname}/"LICENSE "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
-}
-
-post_upgrade() {
- echo "Make sure to upgrade wlroots-git and sway-git together."
- echo "Upgrading one but not the other is unsupported."
+ install -Dm644 "${pkgname}/"LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}