summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFerdinand Bachmann2022-01-02 03:55:39 +0100
committerFerdinand Bachmann2022-01-02 03:55:39 +0100
commit5c9078f3d6dc426ae040acb7ddd21a3509fdbc1f (patch)
tree228946b6af41b770c3bcad5c595ebe7a09bbc5b1
parent4199586d3a0b0fdd191f9607409efaf12d6ec42b (diff)
downloadaur-5c9078f3d6dc426ae040acb7ddd21a3509fdbc1f.tar.gz
build wlroots with address sanitizer
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD10
2 files changed, 12 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0d5b32b3d881..3c8967713051 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
-pkgbase = wlroots-git
- pkgdesc = Modular Wayland compositor library (git version)
- pkgver = 0.14.0.r439.g0fcc8422
+pkgbase = wlroots-asan-git
+ pkgdesc = Modular Wayland compositor library (git version, with address sanitizer)
+ pkgver = 0.15.0.r9.g9988eb33
pkgrel = 1
url = https://gitlab.freedesktop.org/wlroots/wlroots
arch = x86_64
@@ -25,10 +25,11 @@ pkgbase = wlroots-git
depends = vulkan-validation-layers
depends = xorg-xwayland
provides = libwlroots.so
- provides = wlroots=0.14.0
+ provides = wlroots=0.15.0
+ provides = wlroots-git=0.15.0.r9.g9988eb33
conflicts = wlroots
options = debug
- source = wlroots-git::git+https://gitlab.freedesktop.org/wlroots/wlroots
+ source = wlroots-asan-git::git+https://gitlab.freedesktop.org/wlroots/wlroots
sha512sums = SKIP
-pkgname = wlroots-git
+pkgname = wlroots-asan-git
diff --git a/PKGBUILD b/PKGBUILD
index daa668e4e348..b82abd04847d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Adrian Perez de Castro <aperez@igalia.com>
# Maintainer: Antonin Décimo <antonin dot decimo at gmail dot com>
-pkgname=wlroots-git
-pkgver=0.14.0.r439.g0fcc8422
+pkgname=wlroots-asan-git
+pkgver=0.15.0.r9.g9988eb33
pkgrel=1
license=(custom:MIT)
-pkgdesc='Modular Wayland compositor library (git version)'
+pkgdesc='Modular Wayland compositor library (git version, with address sanitizer)'
url=https://gitlab.freedesktop.org/wlroots/wlroots
arch=(x86_64)
-provides=("libwlroots.so" "wlroots=${pkgver%%.r*}")
+provides=("libwlroots.so" "wlroots=${pkgver%%.r*}" "wlroots-git=${pkgver}")
conflicts=(wlroots)
options=(debug)
depends=(
@@ -44,7 +44,7 @@ pkgver () {
}
build () {
- arch-meson \
+ CFLAGS="$CFLAGS -fsanitize=address,undefined" arch-meson \
--buildtype=debug \
-Dwerror=false \
-Dexamples=false \