summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFerdinand Bachmann2022-02-25 14:44:56 +0100
committerFerdinand Bachmann2022-02-25 14:44:56 +0100
commit6a724063dc16c7c215a3b340d05c5a8963edecb0 (patch)
treec7e56611a494cf913e1f9dd44aae3506ea329652
parentb074477e954ff07acfe5e5c9d7c90492a0f75a01 (diff)
parent5f08842925175d4bd152dba3784fd1dc7c653811 (diff)
downloadaur-6a724063dc16c7c215a3b340d05c5a8963edecb0.tar.gz
merge upstream changes
-rw-r--r--PKGBUILD16
1 files changed, 9 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3e0cd8cd4341..7e9cb68852c1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -35,23 +35,25 @@ makedepends=(
source=("${_pkgname}::git+${url}.git")
md5sums=('SKIP')
-_meson_configure() {
- local _builddir="$1"
+_builddir="build"
+_builddir_pkgver="build-pkgver"
+
+_meson_setup () {
CFLAGS="$CFLAGS -fsanitize=address,undefined" arch-meson \
--buildtype=debug \
-Dwerror=false \
-Dexamples=false \
- "${_pkgname}" "${_builddir}"
+ "${_pkgname}" "$1"
}
prepare () {
- _meson_configure build-pkgver
+ _meson_setup "${_builddir_pkgver}"
}
pkgver () {
(
set -o pipefail
- meson introspect --projectinfo build-pkgver \
+ meson introspect --projectinfo "${_builddir_pkgver}" \
| awk 'match($0, /"version":\s*"([[:digit:]]+\.[[:digit:]]+\.[[:digit:]]+)"/, ret) {printf "%s",ret[1]}'
)
cd "${_pkgname}"
@@ -59,8 +61,8 @@ pkgver () {
}
build () {
- _meson_configure build
- meson compile -C build
+ _meson_setup "${_builddir}"
+ meson compile -C "${_builddir}"
}
package () {