summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFerdinand Bachmann2022-02-25 14:40:13 +0100
committerFerdinand Bachmann2022-02-25 14:40:13 +0100
commitb074477e954ff07acfe5e5c9d7c90492a0f75a01 (patch)
treef7aa370a041220d9cff2c63bf61a26232c3abdbc
parent75f449af90c2729d427108d26204e8ac91ae3bf7 (diff)
downloadaur-b074477e954ff07acfe5e5c9d7c90492a0f75a01.tar.gz
rename source directory to "wlroots" instead of "wlroots-asan-git"
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
2 files changed, 9 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 755e97477beb..2c1705dc7bd4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = wlroots-asan-git
pkgdesc = Modular Wayland compositor library (git version, with address sanitizer)
- pkgver = 0.16.0.r5337.da2491d4
+ pkgver = 0.16.0.r5387.e279266f
pkgrel = 1
url = https://gitlab.freedesktop.org/wlroots/wlroots
arch = x86_64
@@ -26,10 +26,10 @@ pkgbase = wlroots-asan-git
depends = xorg-xwayland
provides = libwlroots.so
provides = wlroots=0.16.0
- provides = wlroots-git=0.16.0.r5337.da2491d4
+ provides = wlroots-git=0.16.0.r5387.e279266f
conflicts = wlroots
options = debug
- source = wlroots-asan-git::git+https://gitlab.freedesktop.org/wlroots/wlroots.git
+ source = wlroots::git+https://gitlab.freedesktop.org/wlroots/wlroots.git
md5sums = SKIP
pkgname = wlroots-asan-git
diff --git a/PKGBUILD b/PKGBUILD
index 412b80755218..3e0cd8cd4341 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
# Maintainer: Adrian Perez de Castro <aperez@igalia.com>
# Maintainer: Antonin Décimo <antonin dot decimo at gmail dot com>
pkgname=wlroots-asan-git
-pkgver=0.16.0.r5337.da2491d4
+_pkgname=wlroots
+pkgver=0.16.0.r5387.e279266f
pkgrel=1
license=(custom:MIT)
pkgdesc='Modular Wayland compositor library (git version, with address sanitizer)'
@@ -31,7 +32,7 @@ makedepends=(
vulkan-headers
wayland-protocols
xorgproto)
-source=("${pkgname}::git+${url}.git")
+source=("${_pkgname}::git+${url}.git")
md5sums=('SKIP')
_meson_configure() {
@@ -40,7 +41,7 @@ _meson_configure() {
--buildtype=debug \
-Dwerror=false \
-Dexamples=false \
- "${pkgname}" "${_builddir}"
+ "${_pkgname}" "${_builddir}"
}
prepare () {
@@ -53,7 +54,7 @@ pkgver () {
meson introspect --projectinfo build-pkgver \
| awk 'match($0, /"version":\s*"([[:digit:]]+\.[[:digit:]]+\.[[:digit:]]+)"/, ret) {printf "%s",ret[1]}'
)
- cd "${pkgname}"
+ cd "${_pkgname}"
printf ".r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
@@ -64,7 +65,7 @@ build () {
package () {
DESTDIR="${pkgdir}" meson install -C build
- install -Dm644 "${pkgname}/"LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 "${_pkgname}/"LICENSE "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
}
post_upgrade() {