summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFerdinand Bachmann2022-01-23 23:09:36 +0100
committerFerdinand Bachmann2022-01-23 23:09:36 +0100
commitb4e2d34aafdd8676e203776707d93b97562b9faf (patch)
tree072d0933a7308dbbfaa13c63c31e966568c13391
parentf957d6bf97bcb9c40512fa9e3c91d0726388bcf6 (diff)
downloadaur-b4e2d34aafdd8676e203776707d93b97562b9faf.tar.gz
fix prepare breaking debug prefix map somehow
-rw-r--r--PKGBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5f56d06c5e10..3b9dc23c63db 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -34,18 +34,23 @@ makedepends=(
source=("${pkgname}::git+${url}.git")
md5sums=('SKIP')
-prepare () {
+_meson_configure() {
+ local _builddir="$1"
CFLAGS="$CFLAGS -fsanitize=address,undefined" arch-meson \
--buildtype=debug \
-Dwerror=false \
-Dexamples=false \
- "${pkgname}" build
+ "${pkgname}" "${_builddir}"
+}
+
+prepare () {
+ _meson_configure build-pkgver
}
pkgver () {
(
set -o pipefail
- meson introspect --projectinfo build \
+ meson introspect --projectinfo build-pkgver \
| awk 'match($0, /"version":\s*"([[:digit:]]+\.[[:digit:]]+\.[[:digit:]]+)"/, ret) {printf "%s",ret[1]}'
)
cd "${pkgname}"
@@ -53,6 +58,7 @@ pkgver () {
}
build () {
+ _meson_configure build
meson compile -C build
}