summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFerdinand Bachmann2024-01-29 18:21:02 +0100
committerFerdinand Bachmann2024-01-29 18:21:02 +0100
commitee11c51dc913412a5329fcfb51d408120baeedba (patch)
tree35a7b75e87b7ceb8c6fa656de217c703958e4c7a
parent3daf433cabc00f862950c95defb187dcf107670e (diff)
downloadaur-ee11c51dc913412a5329fcfb51d408120baeedba.tar.gz
PKGBUILD: use meson's built-in sanitizer support
-rw-r--r--PKGBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d0bb8687fcc0..c997108042f0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -47,8 +47,9 @@ _builddir="build"
_builddir_pkgver="build-pkgver"
_meson_setup() {
- CFLAGS="$CFLAGS -fsanitize=address,undefined" arch-meson \
+ arch-meson \
--buildtype=debug \
+ -Db_sanitize=address,undefined \
-Dwerror=false \
-Dexamples=false \
"${pkgname}" "$1"