summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFerdinand Bachmann2022-01-23 22:52:48 +0100
committerFerdinand Bachmann2022-01-23 22:52:48 +0100
commitf957d6bf97bcb9c40512fa9e3c91d0726388bcf6 (patch)
tree2957b3450d0f7cf6e139b7ffef6eb7cfc7d4c0a4
parent5c9078f3d6dc426ae040acb7ddd21a3509fdbc1f (diff)
parentd54e6557b54615d3c2211e4576159342fec485eb (diff)
downloadaur-f957d6bf97bcb9c40512fa9e3c91d0726388bcf6.tar.gz
merge upstream changes
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD26
2 files changed, 20 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3c8967713051..e91380577325 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = wlroots-asan-git
pkgdesc = Modular Wayland compositor library (git version, with address sanitizer)
- pkgver = 0.15.0.r9.g9988eb33
+ pkgver = 0.16.0.r5320.6cdf843a
pkgrel = 1
url = https://gitlab.freedesktop.org/wlroots/wlroots
arch = x86_64
@@ -25,11 +25,11 @@ pkgbase = wlroots-asan-git
depends = vulkan-validation-layers
depends = xorg-xwayland
provides = libwlroots.so
- provides = wlroots=0.15.0
- provides = wlroots-git=0.15.0.r9.g9988eb33
+ provides = wlroots=0.16.0
+ provides = wlroots-git=0.16.0.r5320.6cdf843a
conflicts = wlroots
options = debug
- source = wlroots-asan-git::git+https://gitlab.freedesktop.org/wlroots/wlroots
- sha512sums = SKIP
+ source = wlroots-asan-git::git+https://gitlab.freedesktop.org/wlroots/wlroots.git
+ md5sums = SKIP
pkgname = wlroots-asan-git
diff --git a/PKGBUILD b/PKGBUILD
index b82abd04847d..5f56d06c5e10 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Adrian Perez de Castro <aperez@igalia.com>
# Maintainer: Antonin Décimo <antonin dot decimo at gmail dot com>
pkgname=wlroots-asan-git
-pkgver=0.15.0.r9.g9988eb33
+pkgver=0.16.0.r5320.6cdf843a
pkgrel=1
license=(custom:MIT)
pkgdesc='Modular Wayland compositor library (git version, with address sanitizer)'
@@ -31,24 +31,28 @@ makedepends=(
vulkan-headers
wayland-protocols
xorgproto)
-source=("${pkgname}::git+${url}")
-sha512sums=('SKIP')
+source=("${pkgname}::git+${url}.git")
+md5sums=('SKIP')
+
+prepare () {
+ CFLAGS="$CFLAGS -fsanitize=address,undefined" arch-meson \
+ --buildtype=debug \
+ -Dwerror=false \
+ -Dexamples=false \
+ "${pkgname}" build
+}
pkgver () {
- cd "${pkgname}"
(
set -o pipefail
- git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ meson introspect --projectinfo build \
+ | awk 'match($0, /"version":\s*"([[:digit:]]+\.[[:digit:]]+\.[[:digit:]]+)"/, ret) {printf "%s",ret[1]}'
)
+ cd "${pkgname}"
+ printf ".r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build () {
- CFLAGS="$CFLAGS -fsanitize=address,undefined" arch-meson \
- --buildtype=debug \
- -Dwerror=false \
- -Dexamples=false \
- "${pkgname}" build
meson compile -C build
}