summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDanilo Bargen2021-05-02 01:10:28 +0200
committerDanilo Bargen2021-05-02 01:10:35 +0200
commit2205a4aa25bebef2c29901e21bc7554623e28ffc (patch)
tree14692cfce592ac00499db3536a353ee6bb3fd7b1
downloadaur-2205a4aa25bebef2c29901e21bc7554623e28ffc.tar.gz
Initial version
-rw-r--r--.SRCINFO35
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD63
3 files changed, 102 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..080bc43963d6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,35 @@
+# Generated by mksrcinfo v8
+# Sat May 1 23:10:30 UTC 2021
+pkgbase = wlroots-eglstreams-git
+ pkgdesc = Modular Wayland compositor library with EGLStream support (git version)
+ pkgver = 0.12.0.r518.g42d5ba18
+ pkgrel = 1
+ url = https://github.com/danvd/wlroots-eglstreams
+ arch = x86_64
+ license = custom:MIT
+ makedepends = git
+ makedepends = meson
+ makedepends = wayland-protocols
+ makedepends = xorgproto
+ depends = libinput
+ depends = libxcb
+ depends = libxkbcommon
+ depends = opengl-driver
+ depends = pixman
+ depends = wayland
+ depends = xcb-util-errors
+ depends = xcb-util-renderutil
+ depends = xcb-util-wm
+ depends = seatd
+ depends = systemd
+ depends = xorg-xwayland
+ provides = wlroots=0.12.0
+ provides = wlroots-git
+ conflicts = wlroots
+ conflicts = wlroots-git
+ options = debug
+ source = wlroots-eglstreams-git::git+https://github.com/danvd/wlroots-eglstreams
+ sha512sums = SKIP
+
+pkgname = wlroots-eglstreams-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..d2a23984aa54
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+*.pkg.tar.xz
+wlroots-eglstreams-git/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..188e09ef9d80
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,63 @@
+# Maintainer: Danilo Bargen <aur ät dbrgn döt ch>
+# Forked from wlroots-git PKGBUILD in early May 2021
+pkgname=wlroots-eglstreams-git
+pkgver=0.12.0.r518.g42d5ba18
+pkgrel=1
+license=(custom:MIT)
+pkgdesc='Modular Wayland compositor library with EGLStream support (git version)'
+url=https://github.com/danvd/wlroots-eglstreams
+arch=(x86_64)
+provides=("wlroots=${pkgver%%.r*}" wlroots-git)
+conflicts=(wlroots wlroots-git)
+options=(debug)
+depends=(
+ libinput
+ libxcb
+ libxkbcommon
+ opengl-driver
+ pixman
+ wayland
+ xcb-util-errors
+ xcb-util-renderutil
+ xcb-util-wm
+ seatd
+ systemd
+ xorg-xwayland)
+makedepends=(
+ git
+ meson
+ wayland-protocols
+ xorgproto
+)
+source=("${pkgname}::git+${url}")
+sha512sums=('SKIP')
+
+pkgver () {
+ cd "${pkgname}"
+ (
+ set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+build () {
+ arch-meson \
+ --buildtype=debug \
+ -Dlogind-provider=systemd \
+ -Dlibseat=enabled \
+ -Dwerror=false \
+ -Dexamples=false \
+ "${pkgname}" build
+ meson compile -C build
+}
+
+package () {
+ DESTDIR="${pkgdir}" meson install -C build
+ install -Dm644 "${pkgname}/"LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+post_upgrade() {
+ echo "Make sure to upgrade wlroots-eglstream-git and sway-git together."
+ echo "Upgrading one but not the other is unsupported."
+}