summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormonosans2021-08-17 20:05:39 +0300
committermonosans2021-08-17 20:05:39 +0300
commit24068b9051e7b457208b5b082a7f392f8bca6f1c (patch)
tree184a2ea46142fa33b8a5ab6d4368e70491f70daf
parent2205a4aa25bebef2c29901e21bc7554623e28ffc (diff)
downloadaur-24068b9051e7b457208b5b082a7f392f8bca6f1c.tar.gz
Update
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD30
3 files changed, 24 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 080bc43963d6..b2f20da9b016 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
-# Generated by mksrcinfo v8
-# Sat May 1 23:10:30 UTC 2021
pkgbase = wlroots-eglstreams-git
- pkgdesc = Modular Wayland compositor library with EGLStream support (git version)
- pkgver = 0.12.0.r518.g42d5ba18
+ pkgdesc = Modular Wayland compositor library with EGLStreams support (git version)
+ pkgver = 0.14.1.r4990.9e3a62e1
pkgrel = 1
url = https://github.com/danvd/wlroots-eglstreams
arch = x86_64
- license = custom:MIT
+ license = MIT
makedepends = git
makedepends = meson
+ makedepends = ninja
makedepends = wayland-protocols
makedepends = xorgproto
depends = libinput
@@ -20,16 +19,15 @@ pkgbase = wlroots-eglstreams-git
depends = xcb-util-errors
depends = xcb-util-renderutil
depends = xcb-util-wm
- depends = seatd
+ depends = libseat
depends = systemd
depends = xorg-xwayland
- provides = wlroots=0.12.0
+ provides = libwlroots.so
+ provides = wlroots=0.14.1
provides = wlroots-git
conflicts = wlroots
conflicts = wlroots-git
- options = debug
source = wlroots-eglstreams-git::git+https://github.com/danvd/wlroots-eglstreams
sha512sums = SKIP
pkgname = wlroots-eglstreams-git
-
diff --git a/.gitignore b/.gitignore
index d2a23984aa54..218620e2fb38 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,4 @@
-pkg/
-src/
-*.pkg.tar.xz
-wlroots-eglstreams-git/
+*
+!/PKGBUILD
+!/.SRCINFO
+!/.gitignore
diff --git a/PKGBUILD b/PKGBUILD
index 188e09ef9d80..34b72e792dd5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
# Maintainer: Danilo Bargen <aur ät dbrgn döt ch>
-# Forked from wlroots-git PKGBUILD in early May 2021
+# Maintainer: monosans
+# Based on wlroots-git PKGBUILD
pkgname=wlroots-eglstreams-git
-pkgver=0.12.0.r518.g42d5ba18
+pkgver=0.14.1.r4990.9e3a62e1
pkgrel=1
-license=(custom:MIT)
-pkgdesc='Modular Wayland compositor library with EGLStream support (git version)'
+license=(MIT)
+pkgdesc='Modular Wayland compositor library with EGLStreams support (git version)'
url=https://github.com/danvd/wlroots-eglstreams
arch=(x86_64)
-provides=("wlroots=${pkgver%%.r*}" wlroots-git)
+provides=("libwlroots.so" "wlroots=${pkgver%%.r*}" wlroots-git)
conflicts=(wlroots wlroots-git)
-options=(debug)
depends=(
libinput
libxcb
@@ -20,30 +20,26 @@ depends=(
xcb-util-errors
xcb-util-renderutil
xcb-util-wm
- seatd
+ libseat
systemd
xorg-xwayland)
makedepends=(
git
meson
+ ninja
wayland-protocols
- xorgproto
-)
+ xorgproto)
source=("${pkgname}::git+${url}")
sha512sums=('SKIP')
pkgver () {
cd "${pkgname}"
- (
- set -o pipefail
- git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
- )
+ echo ${pkgver%%.r*}.r"$(git rev-list --count HEAD)"."$(git rev-parse --short HEAD)"
}
build () {
arch-meson \
- --buildtype=debug \
+ --buildtype=release \
-Dlogind-provider=systemd \
-Dlibseat=enabled \
-Dwerror=false \
@@ -58,6 +54,6 @@ package () {
}
post_upgrade() {
- echo "Make sure to upgrade wlroots-eglstream-git and sway-git together."
- echo "Upgrading one but not the other is unsupported."
+ echo "Make sure to upgrade wlroots-eglstream-git and sway-git together."
+ echo "Upgrading one but not the other is unsupported."
}