summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormonosans2022-02-05 20:47:32 +0300
committermonosans2022-02-05 20:47:32 +0300
commit4e4f7672f2769b8346431e5b3a0f76baba572c76 (patch)
tree7caeee6074036d80583508f6e14716b51d0b2a67
parentbc6649351ff18cc2c1d1dc84334f2cb7769e73f8 (diff)
downloadaur-4e4f7672f2769b8346431e5b3a0f76baba572c76.tar.gz
Rebase on wlroots-git
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD18
2 files changed, 14 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 731bc7070740..136c805123ff 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = wlroots-eglstreams-git
pkgdesc = Modular Wayland compositor library with EGLStreams support (git version)
- pkgver = 0.16.0.r5319.f4578db2
+ pkgver = 0.16.0.r5365.5bde12a6
pkgrel = 1
url = https://github.com/danvd/wlroots-eglstreams
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index dbf92141829b..05a7ccd8be28 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: monosans
# Based on wlroots-git PKGBUILD
pkgname=wlroots-eglstreams-git
-pkgver=0.16.0.r5319.f4578db2
+pkgver=0.16.0.r5365.5bde12a6
pkgrel=1
license=(MIT)
pkgdesc='Modular Wayland compositor library with EGLStreams support (git version)'
@@ -34,18 +34,25 @@ makedepends=(
source=("${pkgname}::git+${url}.git")
md5sums=('SKIP')
-prepare () {
+_builddir="build"
+_builddir_pkgver="build-pkgver"
+
+_meson_setup () {
arch-meson \
--buildtype=release \
-Dwerror=false \
-Dexamples=false \
- "${pkgname}" build
+ "${pkgname}" "$1"
+}
+
+prepare () {
+ _meson_setup "${_builddir_pkgver}"
}
pkgver () {
(
set -o pipefail
- meson introspect --projectinfo build \
+ meson introspect --projectinfo "${_builddir_pkgver}" \
| awk 'match($0, /"version":\s*"([[:digit:]]+\.[[:digit:]]+\.[[:digit:]]+)"/, ret) {printf "%s",ret[1]}'
)
cd "${pkgname}"
@@ -53,7 +60,8 @@ pkgver () {
}
build () {
- meson compile -C build
+ _meson_setup "${_builddir}"
+ meson compile -C "${_builddir}"
}
package () {