summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormonosans2022-01-09 12:06:16 +0300
committermonosans2022-01-09 12:06:16 +0300
commit90d000181c9a4348bb39c5eceb263e47e90d01dc (patch)
tree1e1028f3accd350cd7c5ec289af020c10f5b5dc8
parent04bfea9cacb56fa00fff4c4a4eb39ac4452b2a07 (diff)
downloadaur-90d000181c9a4348bb39c5eceb263e47e90d01dc.tar.gz
Rebase on wlroots-git
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD24
2 files changed, 19 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4abe30170a57..3cd47fc98823 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = wlroots-eglstreams-git
pkgdesc = Modular Wayland compositor library with EGLStreams support (git version)
- pkgver = 0.14.1.r5292.7660c545
+ pkgver = 0.16.0.r5319.f4578db2
pkgrel = 1
url = https://github.com/danvd/wlroots-eglstreams
arch = x86_64
@@ -25,11 +25,11 @@ pkgbase = wlroots-eglstreams-git
depends = vulkan-validation-layers
depends = xorg-xwayland
provides = libwlroots.so
- provides = wlroots=0.14.1
+ provides = wlroots=0.16.0
provides = wlroots-git
conflicts = wlroots
conflicts = wlroots-git
source = wlroots-eglstreams-git::git+https://github.com/danvd/wlroots-eglstreams
- sha512sums = SKIP
+ md5sums = SKIP
pkgname = wlroots-eglstreams-git
diff --git a/PKGBUILD b/PKGBUILD
index ee2f600dc346..e31297029242 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: monosans
# Based on wlroots-git PKGBUILD
pkgname=wlroots-eglstreams-git
-pkgver=0.14.1.r5292.7660c545
+pkgver=0.16.0.r5319.f4578db2
pkgrel=1
license=(MIT)
pkgdesc='Modular Wayland compositor library with EGLStreams support (git version)'
@@ -32,19 +32,27 @@ makedepends=(
wayland-protocols
xorgproto)
source=("${pkgname}::git+${url}")
-sha512sums=('SKIP')
+md5sums=('SKIP')
-pkgver () {
- cd "${pkgname}"
- echo ${pkgver%%.r*}.r"$(git rev-list --count HEAD)"."$(git rev-parse --short HEAD)"
-}
-
-build () {
+prepare () {
arch-meson \
--buildtype=release \
-Dwerror=false \
-Dexamples=false \
"${pkgname}" build
+}
+
+pkgver () {
+ (
+ set -o pipefail
+ meson introspect --projectinfo build \
+ | awk 'match($0, /"version":\s*"([[:digit:]]+\.[[:digit:]]+\.[[:digit:]]+)"/, ret) {printf "%s",ret[1]}'
+ cd "${pkgname}"
+ printf ".r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+build () {
meson compile -C build
}