summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Perez de Castro2018-05-20 02:16:17 +0100
committerAdrian Perez de Castro2018-05-20 02:18:04 +0100
commit74391eabfb6868dad522af8f94053aebef988adb (patch)
treec94328d4b34dcaad222d892b701eb8c5109f7443
parent88cc865ee9301fed65f90a7d232ae85b36b21c9d (diff)
downloadaur-74391eabfb6868dad522af8f94053aebef988adb.tar.gz
Use debug build by default, as per upstream request
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
2 files changed, 9 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c73663990e43..9ea22cdca194 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = wlroots-git
pkgdesc = Modular Wayland compositor library
- pkgver = r2505.7c2241a5
+ pkgver = r2574.8585533a
pkgrel = 1
url = https://github.com/swaywm/wlroots
arch = x86_64
@@ -22,6 +22,8 @@ pkgbase = wlroots-git
depends = libxkbcommon
provides = wlroots
conflicts = wlroots
+ options = debug
+ options = !strip
source = wlroots-git::git+https://github.com/swaywm/wlroots
sha512sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 43d28111157b..428ee3b043d8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Adrian Perez de Castro <aperez@igalia.com>
pkgname='wlroots-git'
-pkgver=r2505.7c2241a5
+pkgver=r2574.8585533a
pkgrel=1
license=('custom:MIT')
pkgdesc='Modular Wayland compositor library'
@@ -8,6 +8,7 @@ url='https://github.com/swaywm/wlroots'
arch=('x86_64')
provides=('wlroots')
conflicts=('wlroots')
+options=('debug' '!strip')
depends=('libcap' 'systemd' 'wayland' 'opengl-driver' 'libxcb'
'xcb-util-errors' 'xcb-util-image' 'xcb-util-wm' 'pixman'
'libinput' 'libxkbcommon')
@@ -30,12 +31,15 @@ build () {
rm -rf build
meson build \
--prefix /usr \
+ --buildtype debug \
-Denable-libcap=true \
-Denable-systemd=true \
-Denable-elogind=false \
-Denable-xcb_errors=true \
-Denable-xwayland=true \
- -Denable-x11_backend=true
+ -Denable-x11_backend=true \
+ -Denable-rootston=true \
+ -Denable-examples=true
ninja -C build
}