summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonin Décimo2021-03-16 10:59:39 +0100
committerAntonin Décimo2021-03-16 10:59:39 +0100
commit394ed9c271aa91fb42da5be30e3eaf1f2c6b5bac (patch)
tree97647f9ea962b127a1be9463f91b272cb9195ea5
parent95f8a9215a2adcdeccaebbc7af6ad90c0ee7e5fb (diff)
downloadaur-394ed9c271aa91fb42da5be30e3eaf1f2c6b5bac.tar.gz
Update dependencies and use only meson
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD50
2 files changed, 41 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 66c460e1a911..f75c633a28d1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,26 @@
pkgbase = wlroots-git
- pkgdesc = Modular Wayland compositor library
- pkgver = 0.11.0.r71.g85757665
+ pkgdesc = Modular Wayland compositor library (git version)
+ pkgver = 0.12.0.r378.g00bee2a6
pkgrel = 1
url = https://github.com/swaywm/wlroots
arch = x86_64
license = custom:MIT
- makedepends = meson
- makedepends = ninja
makedepends = git
+ makedepends = meson
makedepends = wayland-protocols
makedepends = xorgproto
- depends = systemd
- depends = wayland
- depends = opengl-driver
+ depends = libinput
depends = libxcb
+ depends = libxkbcommon
+ depends = opengl-driver
+ depends = pixman
+ depends = wayland
depends = xcb-util-errors
+ depends = xcb-util-renderutil
depends = xcb-util-wm
- depends = pixman
- depends = libinput
- depends = libxkbcommon
- provides = wlroots=0.11.0
+ depends = systemd
+ depends = xorg-xwayland
+ provides = wlroots=0.12.0
conflicts = wlroots
options = debug
source = wlroots-git::git+https://github.com/swaywm/wlroots
diff --git a/PKGBUILD b/PKGBUILD
index 090d32f0ec1a..c944b0273db2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,35 @@
# Maintainer: Adrian Perez de Castro <aperez@igalia.com>
+# Maintainer: Antonin Décimo <antonin dot decimo at gmail dot com>
pkgname=wlroots-git
-pkgver=0.11.0.r71.g85757665
+pkgver=0.12.0.r378.g00bee2a6
pkgrel=1
license=(custom:MIT)
-pkgdesc='Modular Wayland compositor library'
+pkgdesc='Modular Wayland compositor library (git version)'
url=https://github.com/swaywm/wlroots
arch=(x86_64)
provides=("wlroots=${pkgver%%.r*}")
conflicts=(wlroots)
options=(debug)
-depends=(systemd wayland opengl-driver libxcb xcb-util-errors
- xcb-util-wm pixman libinput libxkbcommon)
-makedepends=(meson ninja git wayland-protocols xorgproto)
+depends=(
+ libinput
+ libxcb
+ libxkbcommon
+ opengl-driver
+ pixman
+ wayland
+ xcb-util-errors
+ xcb-util-renderutil
+ xcb-util-wm
+ systemd
+ xorg-xwayland)
+makedepends=(
+ git
+ meson
+ wayland-protocols
+ xorgproto)
source=("${pkgname}::git+${url}")
sha512sums=('SKIP')
-
pkgver () {
cd "${pkgname}"
(
@@ -26,23 +40,17 @@ pkgver () {
}
build () {
- cd "${pkgname}"
- rm -rf build
- meson build \
- --prefix /usr \
- --buildtype debug \
- -Dlogind=enabled \
+ arch-meson \
+ --buildtype=debug \
-Dlogind-provider=systemd \
- -Dxcb-errors=enabled \
- -Dxcb-icccm=enabled \
- -Dxwayland=enabled \
- -Dx11-backend=enabled \
- -Dexamples=false
- ninja -C build
+ -Dlibseat=disabled \
+ -Dwerror=false \
+ -Dexamples=false \
+ "${pkgname}" build
+ meson compile -C build
}
package () {
- cd "${pkgname}"
- DESTDIR="${pkgdir}" ninja -C build install
- install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ DESTDIR="${pkgdir}" meson install -C build
+ install -Dm644 "${pkgname}/"LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}