summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosip Janzic2021-06-03 21:35:20 +0200
committerJosip Janzic2021-06-03 21:35:20 +0200
commitaa3547a5057b812e41795db0424f93ba3e8eba39 (patch)
tree5c78d0191f4a8b487c770e301d0b5574359e2e3f
parent044789b252c57b33b2d7bb3db7e5d8f89d1d7b58 (diff)
downloadaur-aa3547a5057b812e41795db0424f93ba3e8eba39.tar.gz
Use dynamic patch instead of github branch
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD17
2 files changed, 18 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0d63f4422cc1..de8f968f498e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = wlroots-hi-res-scroll-git
pkgdesc = Modular Wayland compositor library with hi-res scroll patches (git version)
- pkgver = 0.13.0.r95.g8e9e6e1a
+ pkgver = 0.13.0.r153.g9e58301d
pkgrel = 1
- url = https://github.com/janza/wlroots
+ url = https://github.com/swaywm/wlroots
arch = x86_64
license = custom:MIT
makedepends = git
@@ -25,8 +25,9 @@ pkgbase = wlroots-hi-res-scroll-git
provides = wlroots-git
conflicts = wlroots
options = debug
- source = wlroots-hi-res-scroll-git::git+https://github.com/janza/wlroots
+ source = wlroots-hi-res-scroll-git::git+https://github.com/swaywm/wlroots
+ source = hi_res_scroll.diff::https://github.com/swaywm/wlroots/compare/master...janza:master.diff
sha512sums = SKIP
+ sha512sums = a7eec598fa659a9118826d26596c7b8baea4b6fc7297195039726dee961f22aca7d9627b40498d1c490644657244198a31577c5b1bc66ae8a99f2d0b5d460949
pkgname = wlroots-hi-res-scroll-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 19a7addad609..f13f2b747621 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,11 +2,11 @@
# Contributor: Adrian Perez de Castro <aperez@igalia.com>
# Contributor: Antonin Décimo <antonin dot decimo at gmail dot com>
pkgname=wlroots-hi-res-scroll-git
-pkgver=0.13.0.r95.g8e9e6e1a
+pkgver=0.13.0.r153.g9e58301d
pkgrel=1
license=(custom:MIT)
pkgdesc='Modular Wayland compositor library with hi-res scroll patches (git version)'
-url=https://github.com/janza/wlroots
+url=https://github.com/swaywm/wlroots
arch=(x86_64)
provides=("wlroots=${pkgver%%.r*}" "wlroots-git")
conflicts=(wlroots)
@@ -29,8 +29,12 @@ makedepends=(
meson
wayland-protocols
xorgproto)
-source=("${pkgname}::git+${url}")
-sha512sums=('SKIP')
+source=("${pkgname}::git+${url}"
+ # "hi_res_scroll.diff::https://github.com/swaywm/wlroots/pull/2064.diff"
+ "hi_res_scroll.diff::https://github.com/swaywm/wlroots/compare/master...janza:master.diff"
+ )
+sha512sums=('SKIP'
+ 'a7eec598fa659a9118826d26596c7b8baea4b6fc7297195039726dee961f22aca7d9627b40498d1c490644657244198a31577c5b1bc66ae8a99f2d0b5d460949')
pkgver () {
cd "${pkgname}"
@@ -41,6 +45,11 @@ pkgver () {
)
}
+prepare () {
+ cd "${pkgname}"
+ patch --forward --strip=1 --input="${srcdir}/hi_res_scroll.diff"
+}
+
build () {
arch-meson \
--buildtype=debug \