summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonin Décimo2021-10-18 17:59:05 +0200
committerAntonin Décimo2021-10-18 17:59:05 +0200
commit1fce9c70422c952f3afb7065519a8bc67b1222fc (patch)
treeba55e6e4fc9280d1cfcd0139de98d07821bbfd70
parente8aab974fdbada9057450ed0e1d229c19ba050c2 (diff)
downloadaur-1fce9c70422c952f3afb7065519a8bc67b1222fc.tar.gz
Update package and dependencies for Vulkan renderer
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD12
2 files changed, 15 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1adf01368f34..6e64f9e8176f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,16 @@
pkgbase = wlroots-hidpi-git
pkgdesc = Modular Wayland compositor library, with XWayland HiDPI (git version)
- pkgver = 0.14.0.r239.g9579d62a
+ pkgver = 0.14.0.r303.gf7ea33da
pkgrel = 1
url = https://github.com/swaywm/wlroots
arch = x86_64
license = custom:MIT
makedepends = git
makedepends = meson
+ makedepends = vulkan-headers
makedepends = wayland-protocols
makedepends = xorgproto
+ depends = glslang
depends = libinput
depends = libxcb
depends = libxkbcommon
@@ -19,7 +21,8 @@ pkgbase = wlroots-hidpi-git
depends = xcb-util-renderutil
depends = xcb-util-wm
depends = seatd
- depends = systemd
+ depends = vulkan-icd-loader
+ depends = xorg-xwayland
provides = libwlroots.so
provides = wlroots=0.14.0
conflicts = wlroots
@@ -27,7 +30,7 @@ pkgbase = wlroots-hidpi-git
options = debug
source = wlroots-hidpi-git::git+https://github.com/swaywm/wlroots
source = xwayland_hidpi.diff::https://github.com/swaywm/wlroots/compare/master...MisterDA:xwayland_hidpi.diff
- sha512sums = SKIP
- sha512sums = eade099a5db472a3feb6617a03c588e04a980ee474211461bc5d69dcaf09493f6ce55498e649aadf5808a996e52abb24cc32d9107e8400bf93ea17d2f6ba1a2a
+ sha256sums = SKIP
+ sha256sums = bd3a5295c404be332372d1504177d1e7c7fd8649b0bc9ef603c586843a46f4b4
pkgname = wlroots-hidpi-git
diff --git a/PKGBUILD b/PKGBUILD
index 07f5d0ac5b9b..ed0dc8d450ed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Antonin Décimo <antonin dot decimo at gmail dot com>
# Contributor: Adrian Perez de Castro <aperez@igalia.com>
pkgname=wlroots-hidpi-git
-pkgver=0.14.0.r239.g9579d62a
+pkgver=0.14.0.r303.gf7ea33da
pkgrel=1
license=(custom:MIT)
pkgdesc='Modular Wayland compositor library, with XWayland HiDPI (git version)'
@@ -11,6 +11,7 @@ provides=("libwlroots.so" "wlroots=${pkgver%%.r*}")
conflicts=(wlroots wlroots-git)
options=(debug)
depends=(
+ glslang
libinput
libxcb
libxkbcommon
@@ -21,18 +22,20 @@ depends=(
xcb-util-renderutil
xcb-util-wm
seatd
- systemd)
+ vulkan-icd-loader
+ xorg-xwayland)
makedepends=(
git
meson
+ vulkan-headers
wayland-protocols
xorgproto)
source=("${pkgname}::git+${url}"
# "xwayland_hidpi.diff::https://github.com/swaywm/wlroots/pull/2064.diff"
"xwayland_hidpi.diff::https://github.com/swaywm/wlroots/compare/master...MisterDA:xwayland_hidpi.diff"
)
-sha512sums=('SKIP'
- 'eade099a5db472a3feb6617a03c588e04a980ee474211461bc5d69dcaf09493f6ce55498e649aadf5808a996e52abb24cc32d9107e8400bf93ea17d2f6ba1a2a')
+sha256sums=('SKIP'
+ 'bd3a5295c404be332372d1504177d1e7c7fd8649b0bc9ef603c586843a46f4b4')
pkgver () {
cd "${pkgname}"
@@ -50,6 +53,7 @@ prepare () {
build () {
arch-meson \
+ --buildtype=debug \
-Dwerror=false \
-Dexamples=false \
"${pkgname}" build