summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorq234rty2023-03-10 03:07:11 +0800
committerq234rty2023-03-10 03:07:11 +0800
commit8f14904f40f22b5ad247f022de21875c5a4d1050 (patch)
treeb45b065b0d39c4ce1b00325a8a568aa772954491
parent2ec8808d08d529c016cc8a211ec6aeda92fe46d0 (diff)
downloadaur-8f14904f40f22b5ad247f022de21875c5a4d1050.tar.gz
Rebase patch
-rw-r--r--.SRCINFO8
-rw-r--r--0001-xwayland-support-HiDPI-scale.patch26
-rw-r--r--0002-Fix-configure_notify-event.patch6
-rw-r--r--PKGBUILD8
4 files changed, 24 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 11cd02de1a9c..7ab0c67bce5b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = wlroots-hidpi-xprop-git
pkgdesc = Modular Wayland compositor library (git version, with patches)
- pkgver = 0.17.0.20230306.122351
- pkgrel = 2
+ pkgver = 0.17.0.20230309.185147
+ pkgrel = 1
url = https://gitlab.freedesktop.org/wlroots/wlroots
install = wlroots-hidpi-xprop-git.install
arch = x86_64
@@ -38,7 +38,7 @@ pkgbase = wlroots-hidpi-xprop-git
source = 0001-xwayland-support-HiDPI-scale.patch
source = 0002-Fix-configure_notify-event.patch
sha512sums = SKIP
- sha512sums = e03a3c9ac99645b46d583e6c00b7001bdc05738c1ac906e3e3f60e5893490f8c6da23a45e66a000a208e6ea8987294edd6cb13037b32a48d4e921492dcf0bb36
- sha512sums = 65d50ed5a1cb5b976e02da69280944bdcc924827ac16106750170b28d96aea42ce723366a44dd0b9c27fe6b2b862b9e7c7502570c05690bbcc46f78ac1c22324
+ sha512sums = 0595261b7beaa382f351b74d207956a7d36e05db4e96093d68773975cd2a6d6022a03e2aee927b1286bfd382d7c9d5ec22c747b501c2b0cd9e33f1e031a00022
+ sha512sums = 00c0c841f6c78d941d5128f9e0337dfd36245b74f82b53a73cc453b8cd4b09d3788f5d2d397db5cacd7445f17ff07dd8875954b5d570fcb6468e3b15060cb69a
pkgname = wlroots-hidpi-xprop-git
diff --git a/0001-xwayland-support-HiDPI-scale.patch b/0001-xwayland-support-HiDPI-scale.patch
index a9e86fb3ac31..645986314065 100644
--- a/0001-xwayland-support-HiDPI-scale.patch
+++ b/0001-xwayland-support-HiDPI-scale.patch
@@ -1,7 +1,7 @@
-From 48f97d24d4b7f9d5fd0d4accdbaa009b365bd61b Mon Sep 17 00:00:00 2001
+From 5d04dc68d7a952c2b98cab7af60bba93bee2dec7 Mon Sep 17 00:00:00 2001
From: lilydjwg <lilydjwg@gmail.com>
Date: Wed, 17 Nov 2021 19:34:58 +0800
-Subject: [PATCH] xwayland: support HiDPI scale
+Subject: [PATCH 1/2] xwayland: support HiDPI scale
This supports the xorg-xwayland patch at https://gitlab.freedesktop.org/xorg/xserver/-/merge_requests/733
---
@@ -10,7 +10,7 @@ This supports the xorg-xwayland patch at https://gitlab.freedesktop.org/xorg/xse
2 files changed, 40 insertions(+), 13 deletions(-)
diff --git a/include/xwayland/xwm.h b/include/xwayland/xwm.h
-index c69504e8..1a332b6c 100644
+index 3d540522..33ff1478 100644
--- a/include/xwayland/xwm.h
+++ b/include/xwayland/xwm.h
@@ -88,6 +88,7 @@ enum atom_name {
@@ -21,7 +21,7 @@ index c69504e8..1a332b6c 100644
ATOM_LAST // keep last
};
-@@ -98,6 +99,7 @@ struct wlr_xwm {
+@@ -96,6 +97,7 @@ struct wlr_xwm {
struct wl_event_source *event_source;
struct wlr_seat *seat;
uint32_t ping_timeout;
@@ -30,7 +30,7 @@ index c69504e8..1a332b6c 100644
xcb_atom_t atoms[ATOM_LAST];
xcb_connection_t *xcb_conn;
diff --git a/xwayland/xwm.c b/xwayland/xwm.c
-index 5a36dc21..8449977e 100644
+index 5f857f24..4f03b07c 100644
--- a/xwayland/xwm.c
+++ b/xwayland/xwm.c
@@ -19,6 +19,14 @@
@@ -45,10 +45,10 @@ index 5a36dc21..8449977e 100644
+ return (val + xwm->scale/2) / xwm->scale;
+}
+
- const char *const atom_map[ATOM_LAST] = {
+ static const char *const atom_map[ATOM_LAST] = {
[WL_SURFACE_ID] = "WL_SURFACE_ID",
[WL_SURFACE_SERIAL] = "WL_SURFACE_SERIAL",
-@@ -90,6 +98,7 @@ const char *const atom_map[ATOM_LAST] = {
+@@ -90,6 +98,7 @@ static const char *const atom_map[ATOM_LAST] = {
[DND_ACTION_PRIVATE] = "XdndActionPrivate",
[NET_CLIENT_LIST] = "_NET_CLIENT_LIST",
[NET_CLIENT_LIST_STACKING] = "_NET_CLIENT_LIST_STACKING",
@@ -56,7 +56,7 @@ index 5a36dc21..8449977e 100644
};
#define STARTUP_INFO_REMOVE_PREFIX "remove: ID="
-@@ -968,8 +977,8 @@ static void xwm_handle_create_notify(struct wlr_xwm *xwm,
+@@ -965,8 +974,8 @@ static void xwm_handle_create_notify(struct wlr_xwm *xwm,
return;
}
@@ -67,7 +67,7 @@ index 5a36dc21..8449977e 100644
}
static void xwm_handle_destroy_notify(struct wlr_xwm *xwm,
-@@ -1000,10 +1009,10 @@ static void xwm_handle_configure_request(struct wlr_xwm *xwm,
+@@ -997,10 +1006,10 @@ static void xwm_handle_configure_request(struct wlr_xwm *xwm,
struct wlr_xwayland_surface_configure_event wlr_event = {
.surface = surface,
@@ -82,7 +82,7 @@ index 5a36dc21..8449977e 100644
.mask = mask,
};
-@@ -1018,14 +1027,14 @@ static void xwm_handle_configure_notify(struct wlr_xwm *xwm,
+@@ -1015,14 +1024,14 @@ static void xwm_handle_configure_notify(struct wlr_xwm *xwm,
}
bool geometry_changed =
@@ -103,7 +103,7 @@ index 5a36dc21..8449977e 100644
}
if (xsurface->override_redirect != ev->override_redirect) {
-@@ -1135,7 +1144,22 @@ static void xwm_handle_unmap_notify(struct wlr_xwm *xwm,
+@@ -1132,7 +1141,22 @@ static void xwm_handle_unmap_notify(struct wlr_xwm *xwm,
static void xwm_handle_property_notify(struct wlr_xwm *xwm,
xcb_property_notify_event_t *ev) {
struct wlr_xwayland_surface *xsurface = lookup_surface(xwm, ev->window);
@@ -126,7 +126,7 @@ index 5a36dc21..8449977e 100644
return;
}
-@@ -1772,7 +1796,7 @@ void wlr_xwayland_surface_configure(struct wlr_xwayland_surface *xsurface,
+@@ -1769,7 +1793,7 @@ void wlr_xwayland_surface_configure(struct wlr_xwayland_surface *xsurface,
uint32_t mask = XCB_CONFIG_WINDOW_X | XCB_CONFIG_WINDOW_Y |
XCB_CONFIG_WINDOW_WIDTH | XCB_CONFIG_WINDOW_HEIGHT |
XCB_CONFIG_WINDOW_BORDER_WIDTH;
@@ -135,7 +135,7 @@ index 5a36dc21..8449977e 100644
xcb_configure_window(xwm->xcb_conn, xsurface->window_id, mask, values);
// If the window size did not change, then we cannot rely on
-@@ -2125,6 +2149,7 @@ struct wlr_xwm *xwm_create(struct wlr_xwayland *xwayland, int wm_fd) {
+@@ -2122,6 +2146,7 @@ struct wlr_xwm *xwm_create(struct wlr_xwayland *xwayland, int wm_fd) {
wl_list_init(&xwm->pending_startup_ids);
xwm->ping_timeout = 10000;
diff --git a/0002-Fix-configure_notify-event.patch b/0002-Fix-configure_notify-event.patch
index c80f4795d8ea..4ffc0bfacb09 100644
--- a/0002-Fix-configure_notify-event.patch
+++ b/0002-Fix-configure_notify-event.patch
@@ -1,4 +1,4 @@
-From 950808724d20d8daa1e26d7a0ae322eda14cd1cc Mon Sep 17 00:00:00 2001
+From 2fbf42a76ebf3959fb95a6c0ea66a6f04b032070 Mon Sep 17 00:00:00 2001
From: q234rty <q23456yuiop@gmail.com>
Date: Tue, 21 Feb 2023 23:56:26 +0800
Subject: [PATCH 2/2] Fix configure_notify event
@@ -8,10 +8,10 @@ Subject: [PATCH 2/2] Fix configure_notify event
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/xwayland/xwm.c b/xwayland/xwm.c
-index 8449977e..2cce8a26 100644
+index 4f03b07c..f5ceedb1 100644
--- a/xwayland/xwm.c
+++ b/xwayland/xwm.c
-@@ -1809,10 +1809,10 @@ void wlr_xwayland_surface_configure(struct wlr_xwayland_surface *xsurface,
+@@ -1806,10 +1806,10 @@ void wlr_xwayland_surface_configure(struct wlr_xwayland_surface *xsurface,
.response_type = XCB_CONFIGURE_NOTIFY,
.event = xsurface->window_id,
.window = xsurface->window_id,
diff --git a/PKGBUILD b/PKGBUILD
index 54b34ae3ea02..32e209fa96a1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
# Contributor: Adrian Perez de Castro <aperez@igalia.com>
# Contributor: Antonin Décimo <antonin dot decimo at gmail dot com>
pkgname=wlroots-hidpi-xprop-git
-pkgver=0.17.0.20230306.122351
-pkgrel=2
+pkgver=0.17.0.20230309.185147
+pkgrel=1
license=(MIT)
pkgdesc='Modular Wayland compositor library (git version, with patches)'
url=https://gitlab.freedesktop.org/wlroots/wlroots
@@ -42,8 +42,8 @@ source=("${pkgname}::git+${url}.git"
0001-xwayland-support-HiDPI-scale.patch
0002-Fix-configure_notify-event.patch)
sha512sums=('SKIP'
- 'e03a3c9ac99645b46d583e6c00b7001bdc05738c1ac906e3e3f60e5893490f8c6da23a45e66a000a208e6ea8987294edd6cb13037b32a48d4e921492dcf0bb36'
- '65d50ed5a1cb5b976e02da69280944bdcc924827ac16106750170b28d96aea42ce723366a44dd0b9c27fe6b2b862b9e7c7502570c05690bbcc46f78ac1c22324')
+ '0595261b7beaa382f351b74d207956a7d36e05db4e96093d68773975cd2a6d6022a03e2aee927b1286bfd382d7c9d5ec22c747b501c2b0cd9e33f1e031a00022'
+ '00c0c841f6c78d941d5128f9e0337dfd36245b74f82b53a73cc453b8cd4b09d3788f5d2d397db5cacd7445f17ff07dd8875954b5d570fcb6468e3b15060cb69a')
install=wlroots-hidpi-xprop-git.install
pkgver () {
cd "${pkgname}"