summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorq234rty2023-02-22 00:07:20 +0800
committerq234rty2023-02-22 00:07:20 +0800
commit95056a93083328e45a5e2f2af2124bb8976f7777 (patch)
treeeb5182e3215498737e97f4cd73ccb5f49e6b3de5
parentae5bfb9ea543580498ee76ce97280a497586901e (diff)
downloadaur-95056a93083328e45a5e2f2af2124bb8976f7777.tar.gz
Add a patch
-rw-r--r--.SRCINFO4
-rw-r--r--0002-Fix-configure_notify-event.patch31
-rw-r--r--PKGBUILD9
3 files changed, 40 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 792972a7b4e4..184461f340c5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = wlroots-hidpi-xprop-git
pkgdesc = Modular Wayland compositor library (git version, with patches)
- pkgver = 0.17.0.20230221.103530
+ pkgver = 0.17.0.20230221.115526
pkgrel = 1
url = https://gitlab.freedesktop.org/wlroots/wlroots
install = wlroots-hidpi-xprop-git.install
@@ -35,7 +35,9 @@ pkgbase = wlroots-hidpi-xprop-git
options = debug
source = wlroots-hidpi-xprop-git::git+https://gitlab.freedesktop.org/wlroots/wlroots.git
source = 0001-xwayland-support-HiDPI-scale.patch
+ source = 0002-Fix-configure_notify-event.patch
sha512sums = SKIP
sha512sums = e03a3c9ac99645b46d583e6c00b7001bdc05738c1ac906e3e3f60e5893490f8c6da23a45e66a000a208e6ea8987294edd6cb13037b32a48d4e921492dcf0bb36
+ sha512sums = 65d50ed5a1cb5b976e02da69280944bdcc924827ac16106750170b28d96aea42ce723366a44dd0b9c27fe6b2b862b9e7c7502570c05690bbcc46f78ac1c22324
pkgname = wlroots-hidpi-xprop-git
diff --git a/0002-Fix-configure_notify-event.patch b/0002-Fix-configure_notify-event.patch
new file mode 100644
index 000000000000..c80f4795d8ea
--- /dev/null
+++ b/0002-Fix-configure_notify-event.patch
@@ -0,0 +1,31 @@
+From 950808724d20d8daa1e26d7a0ae322eda14cd1cc Mon Sep 17 00:00:00 2001
+From: q234rty <q23456yuiop@gmail.com>
+Date: Tue, 21 Feb 2023 23:56:26 +0800
+Subject: [PATCH 2/2] Fix configure_notify event
+
+---
+ xwayland/xwm.c | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/xwayland/xwm.c b/xwayland/xwm.c
+index 8449977e..2cce8a26 100644
+--- a/xwayland/xwm.c
++++ b/xwayland/xwm.c
+@@ -1809,10 +1809,10 @@ void wlr_xwayland_surface_configure(struct wlr_xwayland_surface *xsurface,
+ .response_type = XCB_CONFIGURE_NOTIFY,
+ .event = xsurface->window_id,
+ .window = xsurface->window_id,
+- .x = x,
+- .y = y,
+- .width = width,
+- .height = height,
++ .x = values[0],
++ .y = values[1],
++ .width = values[2],
++ .height = values[3],
+ };
+
+ xcb_send_event(xwm->xcb_conn, 0, xsurface->window_id,
+--
+2.39.2
+
diff --git a/PKGBUILD b/PKGBUILD
index 9cde0e086224..8d5f0fda4a36 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Adrian Perez de Castro <aperez@igalia.com>
# Contributor: Antonin Décimo <antonin dot decimo at gmail dot com>
pkgname=wlroots-hidpi-xprop-git
-pkgver=0.17.0.20230221.103530
+pkgver=0.17.0.20230221.115526
pkgrel=1
license=(MIT)
pkgdesc='Modular Wayland compositor library (git version, with patches)'
@@ -38,9 +38,11 @@ makedepends=(
wayland-protocols
xorgproto)
source=("${pkgname}::git+${url}.git"
- 0001-xwayland-support-HiDPI-scale.patch)
+ 0001-xwayland-support-HiDPI-scale.patch
+ 0002-Fix-configure_notify-event.patch)
sha512sums=('SKIP'
- 'e03a3c9ac99645b46d583e6c00b7001bdc05738c1ac906e3e3f60e5893490f8c6da23a45e66a000a208e6ea8987294edd6cb13037b32a48d4e921492dcf0bb36')
+ 'e03a3c9ac99645b46d583e6c00b7001bdc05738c1ac906e3e3f60e5893490f8c6da23a45e66a000a208e6ea8987294edd6cb13037b32a48d4e921492dcf0bb36'
+ '65d50ed5a1cb5b976e02da69280944bdcc924827ac16106750170b28d96aea42ce723366a44dd0b9c27fe6b2b862b9e7c7502570c05690bbcc46f78ac1c22324')
install=wlroots-hidpi-xprop-git.install
pkgver () {
cd "${pkgname}"
@@ -55,6 +57,7 @@ prepare () {
cd "${pkgname}"
git revert -n 18595000f3a21502fd60bf213122859cc348f9af
patch -Np1 < ../0001-xwayland-support-HiDPI-scale.patch
+ patch -Np1 < ../0002-Fix-configure_notify-event.patch
}
build () {