summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorq234rty2023-02-21 23:14:44 +0800
committerq234rty2023-02-21 23:19:08 +0800
commitae5bfb9ea543580498ee76ce97280a497586901e (patch)
tree1d8fc9a0d8d2b599dfefb8eb13c938c48a023e34
parent470bdaa370c8e29ae5f15c4d834ac0d1ce2bfdc5 (diff)
downloadaur-ae5bfb9ea543580498ee76ce97280a497586901e.tar.gz
Rebase patch & Add warning
-rw-r--r--.SRCINFO9
-rw-r--r--0001-xwayland-support-HiDPI-scale.patch (renamed from 6c5ffcd1fee9e44780a6a8792f74ecfbe24a1ca7.patch)51
-rw-r--r--PKGBUILD13
-rw-r--r--wlroots-hidpi-xprop-git.install3
4 files changed, 35 insertions, 41 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6588898fc439..792972a7b4e4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,9 @@
pkgbase = wlroots-hidpi-xprop-git
pkgdesc = Modular Wayland compositor library (git version, with patches)
- pkgver = 0.16.0.20220907.140046
+ pkgver = 0.17.0.20230221.103530
pkgrel = 1
url = https://gitlab.freedesktop.org/wlroots/wlroots
+ install = wlroots-hidpi-xprop-git.install
arch = x86_64
license = MIT
makedepends = git
@@ -27,14 +28,14 @@ pkgbase = wlroots-hidpi-xprop-git
depends = xorg-xwayland
optdepends = xorg-xwayland-hidpi-xprop: HiDPI support, see https://gitlab.freedesktop.org/xorg/xserver/-/merge_requests/733
provides = libwlroots.so
- provides = wlroots=0.16.0
+ provides = wlroots=0.17.0
provides = wlroots-git
conflicts = wlroots
conflicts = wlroots-git
options = debug
source = wlroots-hidpi-xprop-git::git+https://gitlab.freedesktop.org/wlroots/wlroots.git
- source = https://gitlab.freedesktop.org/lilydjwg/wlroots/-/commit/6c5ffcd1fee9e44780a6a8792f74ecfbe24a1ca7.patch
+ source = 0001-xwayland-support-HiDPI-scale.patch
sha512sums = SKIP
- sha512sums = c2193fb6d3063919ecb427a72d09fd11563a9de68e848e9721d7a7d9dc67e700654067ce154b1ddc5fb4587b9cea71d29a73a55a18f54d6ecd60897989677bb2
+ sha512sums = e03a3c9ac99645b46d583e6c00b7001bdc05738c1ac906e3e3f60e5893490f8c6da23a45e66a000a208e6ea8987294edd6cb13037b32a48d4e921492dcf0bb36
pkgname = wlroots-hidpi-xprop-git
diff --git a/6c5ffcd1fee9e44780a6a8792f74ecfbe24a1ca7.patch b/0001-xwayland-support-HiDPI-scale.patch
index 7642b55270f4..a9e86fb3ac31 100644
--- a/6c5ffcd1fee9e44780a6a8792f74ecfbe24a1ca7.patch
+++ b/0001-xwayland-support-HiDPI-scale.patch
@@ -1,4 +1,4 @@
-From 6c5ffcd1fee9e44780a6a8792f74ecfbe24a1ca7 Mon Sep 17 00:00:00 2001
+From 48f97d24d4b7f9d5fd0d4accdbaa009b365bd61b Mon Sep 17 00:00:00 2001
From: lilydjwg <lilydjwg@gmail.com>
Date: Wed, 17 Nov 2021 19:34:58 +0800
Subject: [PATCH] xwayland: support HiDPI scale
@@ -6,14 +6,14 @@ Subject: [PATCH] xwayland: support HiDPI scale
This supports the xorg-xwayland patch at https://gitlab.freedesktop.org/xorg/xserver/-/merge_requests/733
---
include/xwayland/xwm.h | 2 ++
- xwayland/xwm.c | 54 +++++++++++++++++++++++++++++++-----------
- 2 files changed, 42 insertions(+), 14 deletions(-)
+ xwayland/xwm.c | 51 +++++++++++++++++++++++++++++++-----------
+ 2 files changed, 40 insertions(+), 13 deletions(-)
diff --git a/include/xwayland/xwm.h b/include/xwayland/xwm.h
-index 0cdf6ea1..e272a326 100644
+index c69504e8..1a332b6c 100644
--- a/include/xwayland/xwm.h
+++ b/include/xwayland/xwm.h
-@@ -84,6 +84,7 @@ enum atom_name {
+@@ -88,6 +88,7 @@ enum atom_name {
DND_ACTION_PRIVATE,
NET_CLIENT_LIST,
NET_CLIENT_LIST_STACKING,
@@ -21,7 +21,7 @@ index 0cdf6ea1..e272a326 100644
ATOM_LAST // keep last
};
-@@ -94,6 +95,7 @@ struct wlr_xwm {
+@@ -98,6 +99,7 @@ struct wlr_xwm {
struct wl_event_source *event_source;
struct wlr_seat *seat;
uint32_t ping_timeout;
@@ -30,11 +30,11 @@ index 0cdf6ea1..e272a326 100644
xcb_atom_t atoms[ATOM_LAST];
xcb_connection_t *xcb_conn;
diff --git a/xwayland/xwm.c b/xwayland/xwm.c
-index 313bfc0a..1abe2147 100644
+index 5a36dc21..8449977e 100644
--- a/xwayland/xwm.c
+++ b/xwayland/xwm.c
-@@ -20,6 +20,14 @@
- #include "util/signal.h"
+@@ -19,6 +19,14 @@
+ #include <xcb/xfixes.h>
#include "xwayland/xwm.h"
+static int32_t scale(struct wlr_xwm *xwm, uint32_t val) {
@@ -47,8 +47,8 @@ index 313bfc0a..1abe2147 100644
+
const char *const atom_map[ATOM_LAST] = {
[WL_SURFACE_ID] = "WL_SURFACE_ID",
- [WM_DELETE_WINDOW] = "WM_DELETE_WINDOW",
-@@ -89,6 +97,7 @@ const char *const atom_map[ATOM_LAST] = {
+ [WL_SURFACE_SERIAL] = "WL_SURFACE_SERIAL",
+@@ -90,6 +98,7 @@ const char *const atom_map[ATOM_LAST] = {
[DND_ACTION_PRIVATE] = "XdndActionPrivate",
[NET_CLIENT_LIST] = "_NET_CLIENT_LIST",
[NET_CLIENT_LIST_STACKING] = "_NET_CLIENT_LIST_STACKING",
@@ -56,7 +56,7 @@ index 313bfc0a..1abe2147 100644
};
#define STARTUP_INFO_REMOVE_PREFIX "remove: ID="
-@@ -948,8 +957,8 @@ static void xwm_handle_create_notify(struct wlr_xwm *xwm,
+@@ -968,8 +977,8 @@ static void xwm_handle_create_notify(struct wlr_xwm *xwm,
return;
}
@@ -67,7 +67,7 @@ index 313bfc0a..1abe2147 100644
}
static void xwm_handle_destroy_notify(struct wlr_xwm *xwm,
-@@ -980,10 +989,10 @@ static void xwm_handle_configure_request(struct wlr_xwm *xwm,
+@@ -1000,10 +1009,10 @@ static void xwm_handle_configure_request(struct wlr_xwm *xwm,
struct wlr_xwayland_surface_configure_event wlr_event = {
.surface = surface,
@@ -82,7 +82,7 @@ index 313bfc0a..1abe2147 100644
.mask = mask,
};
-@@ -998,14 +1007,14 @@ static void xwm_handle_configure_notify(struct wlr_xwm *xwm,
+@@ -1018,14 +1027,14 @@ static void xwm_handle_configure_notify(struct wlr_xwm *xwm,
}
bool geometry_changed =
@@ -103,7 +103,7 @@ index 313bfc0a..1abe2147 100644
}
if (xsurface->override_redirect != ev->override_redirect) {
-@@ -1114,7 +1123,22 @@ static void xwm_handle_unmap_notify(struct wlr_xwm *xwm,
+@@ -1135,7 +1144,22 @@ static void xwm_handle_unmap_notify(struct wlr_xwm *xwm,
static void xwm_handle_property_notify(struct wlr_xwm *xwm,
xcb_property_notify_event_t *ev) {
struct wlr_xwayland_surface *xsurface = lookup_surface(xwm, ev->window);
@@ -126,27 +126,16 @@ index 313bfc0a..1abe2147 100644
return;
}
-@@ -1708,16 +1732,17 @@ void wlr_xwayland_surface_activate(struct wlr_xwayland_surface *xsurface,
-
- void wlr_xwayland_surface_configure(struct wlr_xwayland_surface *xsurface,
- int16_t x, int16_t y, uint16_t width, uint16_t height) {
-+ struct wlr_xwm *xwm = xsurface->xwm;
-+
- xsurface->x = x;
- xsurface->y = y;
- xsurface->width = width;
- xsurface->height = height;
-
-- struct wlr_xwm *xwm = xsurface->xwm;
+@@ -1772,7 +1796,7 @@ void wlr_xwayland_surface_configure(struct wlr_xwayland_surface *xsurface,
uint32_t mask = XCB_CONFIG_WINDOW_X | XCB_CONFIG_WINDOW_Y |
XCB_CONFIG_WINDOW_WIDTH | XCB_CONFIG_WINDOW_HEIGHT |
XCB_CONFIG_WINDOW_BORDER_WIDTH;
- uint32_t values[] = {x, y, width, height, 0};
+ uint32_t values[] = {scale(xwm, x), scale(xwm, y), scale(xwm, width), scale(xwm, height), 0};
xcb_configure_window(xwm->xcb_conn, xsurface->window_id, mask, values);
- xcb_flush(xwm->xcb_conn);
- }
-@@ -2046,6 +2071,7 @@ struct wlr_xwm *xwm_create(struct wlr_xwayland *xwayland, int wm_fd) {
+
+ // If the window size did not change, then we cannot rely on
+@@ -2125,6 +2149,7 @@ struct wlr_xwm *xwm_create(struct wlr_xwayland *xwayland, int wm_fd) {
wl_list_init(&xwm->pending_startup_ids);
xwm->ping_timeout = 10000;
@@ -155,5 +144,5 @@ index 313bfc0a..1abe2147 100644
int rc = xcb_connection_has_error(xwm->xcb_conn);
--
-GitLab
+2.39.2
diff --git a/PKGBUILD b/PKGBUILD
index d2e358b995c6..9cde0e086224 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Adrian Perez de Castro <aperez@igalia.com>
# Contributor: Antonin Décimo <antonin dot decimo at gmail dot com>
pkgname=wlroots-hidpi-xprop-git
-pkgver=0.16.0.20220907.140046
+pkgver=0.17.0.20230221.103530
pkgrel=1
license=(MIT)
pkgdesc='Modular Wayland compositor library (git version, with patches)'
@@ -38,10 +38,10 @@ makedepends=(
wayland-protocols
xorgproto)
source=("${pkgname}::git+${url}.git"
- https://gitlab.freedesktop.org/lilydjwg/wlroots/-/commit/6c5ffcd1fee9e44780a6a8792f74ecfbe24a1ca7.patch)
+ 0001-xwayland-support-HiDPI-scale.patch)
sha512sums=('SKIP'
- 'c2193fb6d3063919ecb427a72d09fd11563a9de68e848e9721d7a7d9dc67e700654067ce154b1ddc5fb4587b9cea71d29a73a55a18f54d6ecd60897989677bb2')
-
+ 'e03a3c9ac99645b46d583e6c00b7001bdc05738c1ac906e3e3f60e5893490f8c6da23a45e66a000a208e6ea8987294edd6cb13037b32a48d4e921492dcf0bb36')
+install=wlroots-hidpi-xprop-git.install
pkgver () {
cd "${pkgname}"
(
@@ -53,8 +53,8 @@ pkgver () {
prepare () {
cd "${pkgname}"
- git revert -n 18595000f3a21502fd60bf213122859cc348f9af
- patch -Np1 < ../6c5ffcd1fee9e44780a6a8792f74ecfbe24a1ca7.patch
+ git revert -n 18595000f3a21502fd60bf213122859cc348f9af
+ patch -Np1 < ../0001-xwayland-support-HiDPI-scale.patch
}
build () {
@@ -70,3 +70,4 @@ package () {
DESTDIR="${pkgdir}" meson install -C build
install -Dm644 "${pkgname}/"LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
+
diff --git a/wlroots-hidpi-xprop-git.install b/wlroots-hidpi-xprop-git.install
new file mode 100644
index 000000000000..b22a09812bb7
--- /dev/null
+++ b/wlroots-hidpi-xprop-git.install
@@ -0,0 +1,3 @@
+post_upgrade() {
+ echo "Make sure to rebuild sway after updating this."
+}