summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincent Grande2021-04-12 17:54:09 -0400
committerVincent Grande2021-04-12 17:54:09 -0400
commitd486dfb9e872e16da4a19601ff5504fc2e884dbc (patch)
tree98f98c6e43ed1d55f5a4d62594742a32d36f9794
parent034140d0fd4ae260c276001ff66d5b6f48a661c1 (diff)
downloadaur-d486dfb9e872e16da4a19601ff5504fc2e884dbc.tar.gz
big fixes
-rwxr-xr-x[-rw-r--r--].SRCINFO6
-rwxr-xr-x[-rw-r--r--]PKGBUILD15
2 files changed, 16 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 357b856382df..ff8fb529b718 100644..100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,20 @@
pkgbase = wlroots-nosystemd-minimal-git
pkgdesc = Modular Wayland compositor library
- pkgver = 0.10.1
+ pkgver = 0.13.0
pkgrel = 1
url = https://github.com/swaywm/wlroots
arch = x86_64
license = MIT
+ makedepends = git
makedepends = meson
makedepends = ninja
makedepends = wayland-protocols
depends = libinput
+ depends = libxcb
depends = libxkbcommon
depends = opengl-driver
depends = pixman
+ depends = wayland
depends = xcb-util-image
depends = xcb-util-wm
depends = xcb-util-renderutil
@@ -19,6 +22,7 @@ pkgbase = wlroots-nosystemd-minimal-git
provides = libwlroots.so
provides = wlroots
provides = wlroots-git
+ provides = wlroots=0.13.0
conflicts = wlroots
conflicts = wlroots-git
source = git+https://github.com/swaywm/wlroots
diff --git a/PKGBUILD b/PKGBUILD
index 6644b2738e31..8ab874e14171 100644..100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
# Maintainer : Vincent Grande <shoober420@gmail.com>
+# Contributor : Antonin Décimo <antonin dot decimo at gmail dot com>
# Contributor : Adrian Perez de Castro <aperez@igalia.com>
# Contributor : Eric Vidal <eric@obarun.org>
# Contributor : Jean-Michel T.Dydak <jean-michel@obarun.org>
@@ -6,7 +7,7 @@
# Contributor : Omar Pakker
pkgname=wlroots-nosystemd-minimal-git
-pkgver=0.10.1
+pkgver=0.13.0
pkgrel=1
pkgdesc='Modular Wayland compositor library'
url="https://github.com/swaywm/wlroots"
@@ -17,9 +18,11 @@ sha512sums=('SKIP')
depends=(
'libinput'
+ 'libxcb'
'libxkbcommon'
'opengl-driver'
'pixman'
+ 'wayland'
# 'xcb-util-errors'
'xcb-util-image'
'xcb-util-wm'
@@ -27,11 +30,12 @@ depends=(
'xorg-xwayland'
)
makedepends=(
+ 'git'
'meson'
'ninja'
'wayland-protocols'
)
-provides=('libwlroots.so' 'wlroots' 'wlroots-git')
+provides=('libwlroots.so' 'wlroots' 'wlroots-git' "wlroots=${pkgver%%.r*}")
conflicts=('wlroots' 'wlroots-git')
pkgver () {
@@ -49,8 +53,6 @@ _path=(
_flags=(
--buildtype=plain
- -Dlogind=disabled
- -Dlogind-provider=elogind
-Dlibseat=disabled
-Dxcb-errors=disabled
-Dxcb-icccm=enabled
@@ -72,3 +74,8 @@ package() {
DESTDIR="$pkgdir" ninja $NINJAFLAGS -C build install
install -Dm644 "wlroots/LICENSE" -t "$pkgdir/usr/share/licenses/wlroots/"
}
+
+post_upgrade() {
+ echo "Make sure to upgrade wlroots-git and sway-git together."
+ echo "Upgrading one but not the other is unsupported."
+}