summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincent Grande2021-04-12 18:13:53 -0400
committerVincent Grande2021-04-12 18:13:53 -0400
commita2066ee11b8ddd0fe1be473bbfb388b45c54b973 (patch)
tree94cfd01c7b0978c6a73523a086eee15a4eef5160
downloadaur-a2066ee11b8ddd0fe1be473bbfb388b45c54b973.tar.gz
initial upload
-rw-r--r--.SRCINFO32
-rwxr-xr-xPKGBUILD81
2 files changed, 113 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c7658cd0934d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,32 @@
+pkgbase = wlroots-nox11-git
+ pkgdesc = Modular Wayland compositor library
+ pkgver = 0.13.0
+ pkgrel = 1
+ url = https://github.com/swaywm/wlroots
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = meson
+ makedepends = ninja
+ makedepends = wayland-protocols
+ depends = libinput
+ depends = libxcb
+ depends = libxkbcommon
+ depends = opengl-driver
+ depends = pixman
+ depends = wayland
+ depends = xcb-util-errors
+ depends = xcb-util-image
+ depends = xcb-util-wm
+ depends = xcb-util-renderutil
+ provides = libwlroots.so
+ provides = wlroots
+ provides = wlroots-git
+ provides = wlroots=0.13.0
+ conflicts = wlroots
+ conflicts = wlroots-git
+ source = git+https://github.com/swaywm/wlroots
+ sha512sums = SKIP
+
+pkgname = wlroots-nox11-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..212e14ef850c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,81 @@
+# Maintainer : Vincent Grande <shoober420@gmail.com>
+# Contributor : Antonin Décimo <antonin dot decimo at gmail dot com>
+# Contributor : Adrian Perez de Castro <aperez@igalia.com>
+# Contributor : Eric Vidal <eric@obarun.org>
+# Contributor : Jean-Michel T.Dydak <jean-michel@obarun.org>
+# Contributor : Brett Cornwall <ainola@archlinux.org>
+# Contributor : Omar Pakker
+
+pkgname=wlroots-nox11-git
+pkgver=0.13.0
+pkgrel=1
+pkgdesc='Modular Wayland compositor library'
+url="https://github.com/swaywm/wlroots"
+arch=('x86_64')
+license=('MIT')
+source=("git+https://github.com/swaywm/wlroots")
+sha512sums=('SKIP')
+
+depends=(
+ 'libinput'
+ 'libxcb'
+ 'libxkbcommon'
+ 'opengl-driver'
+ 'pixman'
+ 'wayland'
+ 'xcb-util-errors'
+ 'xcb-util-image'
+ 'xcb-util-wm'
+ 'xcb-util-renderutil'
+# 'xorg-xwayland'
+)
+makedepends=(
+ 'git'
+ 'meson'
+ 'ninja'
+ 'wayland-protocols'
+)
+provides=('libwlroots.so' 'wlroots' 'wlroots-git' "wlroots=${pkgver%%.r*}")
+conflicts=('wlroots' 'wlroots-git')
+
+pkgver () {
+ cd wlroots
+ (
+ set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+_path=(
+ --prefix=/usr
+)
+
+_flags=(
+ --buildtype=debug
+ -Dlibseat=auto
+ -Dxcb-errors=enabled
+ -Dxcb-icccm=enabled
+ -Dxcb-xkb=enabled
+ -Dxwayland=enabled
+ -Dx11-backend=enabled
+ -Dexamples=false
+ -Dxdg-foreign=disabled
+ -Db_ndebug=true
+ -Dwerror=false
+)
+
+build() {
+ meson wlroots build "${_path[@]}" "${_flags[@]}"
+ ninja $NINJAFLAGS -C build
+}
+
+package() {
+ DESTDIR="$pkgdir" ninja $NINJAFLAGS -C build install
+ install -Dm644 "wlroots/LICENSE" -t "$pkgdir/usr/share/licenses/wlroots/"
+}
+
+post_upgrade() {
+ echo "Make sure to upgrade wlroots-git and sway-git together."
+ echo "Upgrading one but not the other is unsupported."
+}