summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincent Grande2021-04-12 18:18:46 -0400
committerVincent Grande2021-04-12 18:18:46 -0400
commit2da947a66be4ab35ef0ec675ec64a0c5970d78b0 (patch)
treee6f80a767915a931fc354c249273dca381fb6aa9
parent4bf95338290f83aa8c454dc21a61fac33c1b95f7 (diff)
downloadaur-wlroots-strace-git.tar.gz
big fixes
-rwxr-xr-x[-rw-r--r--].SRCINFO8
-rwxr-xr-x[-rw-r--r--]PKGBUILD18
2 files changed, 21 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2cf3ba0efc5a..dfbd034477df 100644..100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,31 @@
pkgbase = wlroots-strace-git
pkgdesc = Modular Wayland compositor library
- pkgver = 0.10.1
+ pkgver = 0.13.0
pkgrel = 1
url = https://github.com/swaywm/wlroots
arch = x86_64
license = MIT
+ makedepends = git
makedepends = meson
makedepends = ninja
makedepends = wayland-protocols
depends = libinput
+ depends = libxcb
depends = libxkbcommon
depends = opengl-driver
depends = pixman
+ depends = wayland
depends = xcb-util-errors
depends = xcb-util-image
depends = xcb-util-wm
depends = xcb-util-renderutil
depends = xorg-xwayland
+ depends = seatd
+ depends = systemd
provides = libwlroots.so
provides = wlroots
provides = wlroots-git
+ provides = wlroots=0.13.0
conflicts = wlroots
conflicts = wlroots-git
source = git+https://github.com/swaywm/wlroots
diff --git a/PKGBUILD b/PKGBUILD
index f2fa6ad7d2ca..a22105d912e8 100644..100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,13 @@
# Maintainer : Vincent Grande <shoober420@gmail.com>
# Contributor : Adrian Perez de Castro <aperez@igalia.com>
+# Contributor : Antonin Décimo <antonin dot decimo at gmail dot com>
# Contributor : Eric Vidal <eric@obarun.org>
# Contributor : Jean-Michel T.Dydak <jean-michel@obarun.org>
# Contributor : Brett Cornwall <ainola@archlinux.org>
# Contributor : Omar Pakker
pkgname=wlroots-strace-git
-pkgver=0.10.1
+pkgver=0.13.0
pkgrel=1
pkgdesc='Modular Wayland compositor library'
url="https://github.com/swaywm/wlroots"
@@ -17,21 +18,26 @@ sha512sums=('SKIP')
depends=(
'libinput'
+ 'libxcb'
'libxkbcommon'
'opengl-driver'
'pixman'
+ 'wayland'
'xcb-util-errors'
'xcb-util-image'
'xcb-util-wm'
'xcb-util-renderutil'
'xorg-xwayland'
+ 'seatd'
+ 'systemd'
)
makedepends=(
+ 'git'
'meson'
'ninja'
'wayland-protocols'
)
-provides=('libwlroots.so' 'wlroots' 'wlroots-git')
+provides=('libwlroots.so' 'wlroots' 'wlroots-git' "wlroots=${pkgver%%.r*}")
conflicts=('wlroots' 'wlroots-git')
pkgver () {
@@ -49,8 +55,7 @@ _path=(
_flags=(
--buildtype=debug
- -Dlogind=auto
- -Dlogind-provider=auto
+ -Dlibseat=auto
-Dxcb-errors=enabled
-Dxcb-icccm=enabled
-Dxcb-xkb=enabled
@@ -70,3 +75,8 @@ package() {
DESTDIR="$pkgdir" ninja $NINJAFLAGS -C build install
install -Dm644 "wlroots/LICENSE" -t "$pkgdir/usr/share/licenses/wlroots/"
}
+
+post_upgrade() {
+ echo "Make sure to upgrade wlroots-strace-git and sway-strace-git together."
+ echo "Upgrading one but not the other is unsupported."
+}