summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKozak Ivan2020-09-14 22:31:35 +0400
committerKozak Ivan2020-09-14 22:31:35 +0400
commitd6b17c572b29ee8bca89e6f1d77f041a2d151cc6 (patch)
treead61598c1e0b779ef7e15a4fcf9baeb7457738a7
downloadaur-d6b17c572b29ee8bca89e6f1d77f041a2d151cc6.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD29
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e1d643e9068e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = wlsunset-git
+ pkgdesc = Day/night gamma adjustments for Wayland
+ pkgver = efa5b63e
+ pkgrel = 1
+ url = https://git.sr.ht/~kennylevinsen/wlsunset
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = meson
+ makedepends = ninja
+ depends = wayland
+ provides = wlsunset
+ conflicts = wlsunset
+ source = wlsunset-git::git+https://git.sr.ht/~kennylevinsen/wlsunset
+ sha256sums = SKIP
+
+pkgname = wlsunset-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9ce6c4d77ba0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+pkgname=wlsunset-git
+pkgver=efa5b63e
+pkgrel=1
+pkgdesc="Day/night gamma adjustments for Wayland"
+arch=('x86_64')
+url="https://git.sr.ht/~kennylevinsen/wlsunset"
+license=('MIT')
+depends=('wayland')
+makedepends=('git' 'meson' 'ninja')
+provides=('wlsunset')
+conflicts=('wlsunset')
+source=("$pkgname::git+$url")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ git rev-parse HEAD | cut -b1-8
+}
+
+build() {
+ cd "$pkgname"
+ arch-meson build
+ ninja -C build
+}
+
+package() {
+ cd "$pkgname"
+ DESTDIR="$pkgdir" ninja -C build install
+}