summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJason Nader2021-11-13 08:10:51 +0900
committerJason Nader2021-11-13 08:10:51 +0900
commit87ac141c429df78bc39477e580b4a4f95828b04d (patch)
tree108d368978534f703a5cd5fb63b263dd7af014dc
parent03e01b83a9a40307c0006eca86ef06c764de1351 (diff)
downloadaur-87ac141c429df78bc39477e580b4a4f95828b04d.tar.gz
Conform to packaging guidelines
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD17
2 files changed, 11 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index de1513c90b7a..9dcd73f3cc91 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -4,21 +4,16 @@ pkgbase = wlvncc-git
pkgrel = 1
url = https://github.com/any1/wlvncc
arch = x86_64
- arch = i686
- arch = aarch64
- arch = armv7h
license = custom:ISC
makedepends = git
makedepends = meson
- makedepends = ninja
- makedepends = pkg-config
makedepends = wayland-protocols
depends = aml-git
depends = libvncserver-git
depends = libxkbcommon
depends = pixman
depends = wayland
- provides = wlvncc=r43.1ca82ce
+ provides = wlvncc
conflicts = wlvncc
source = git+https://github.com/any1/wlvncc
sha512sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 54ab71bdcec2..3c7b2847ed0f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,27 +3,30 @@ _pkgname=wlvncc
pkgver=r43.1ca82ce
pkgrel=1
pkgdesc='Wayland native VNC client'
-arch=(x86_64 i686 aarch64 armv7h)
+arch=(x86_64)
url=https://github.com/any1/wlvncc
license=(custom:ISC)
depends=(aml-git libvncserver-git libxkbcommon pixman wayland)
-makedepends=(git meson ninja pkg-config wayland-protocols)
+makedepends=(git meson wayland-protocols)
source=("git+$url")
sha512sums=('SKIP')
conflicts=(wlvncc)
-provides=(wlvncc=${pkgver%+*})
+provides=(wlvncc)
pkgver() {
- cd "$_pkgname"
+ cd "$_pkgname"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
}
build() {
- arch-meson wlvncc build # --prefix /usr
- ninja -C build
+ arch-meson wlvncc build
+ meson compile -C build
}
package() {
- DESTDIR="$pkgdir" ninja -C build install
+ meson install -C build --destdir "$pkgdir"
install -Dm 644 wlvncc/COPYING -t "$pkgdir"/usr/share/licenses/$pkgname
}