summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThe-Repo-Club2021-04-02 17:05:13 +0100
committerThe-Repo-Club2021-04-02 17:05:13 +0100
commit5e26a8d0d9bee1c0610c7a783d8013bd74eed2b9 (patch)
tree6b288411467636d050fcf44ea4ee893138faf64d
parentf6a8553f323992259b2ac842c61f1d02f7594d9f (diff)
downloadaur-5e26a8d0d9bee1c0610c7a783d8013bd74eed2b9.tar.gz
Fixed Script and added new functions
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD6
-rwxr-xr-xi3-maim82
3 files changed, 7 insertions, 88 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 52191b3ed8c7..0fe2e26b5966 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = i3-maim
pkgdesc = simple screenshot script using maim
- pkgver = 2021.01.01
+ pkgver = 2021.04.02
pkgrel = 1
url = https://github.com/The-Repo-Club/i3-maim
arch = any
@@ -10,8 +10,9 @@ pkgbase = i3-maim
depends = maim
depends = xdg-user-dirs
depends = xdotool
- source = i3-maim-2021.01.01.tar.gz::https://github.com/The-Repo-Club/i3-maim/archive/2021.01.01.tar.gz
- sha256sums = 39d360b31f4228c6f07aa4c5212bf32a37df27f2b118f5e71311d589efa9833e
+ depends = xclip
+ source = i3-maim-2021.04.02.tar.gz::https://github.com/The-Repo-Club/i3-maim/archive/2021.04.02.tar.gz
+ sha256sums = d6580e29f44c4e688e76de1ff573c97a75380cdcbe0656f22c292e428a8deb4a
pkgname = i3-maim
diff --git a/PKGBUILD b/PKGBUILD
index 7d7ea6d3ce6e..ee14c48d2cf5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,16 @@
# Maintainer: The-Repo-Club <The-Repo-Club@github.com>
# Contributor: The-Repo-Club <The-Repo-Club@github.com>
pkgname=i3-maim
-pkgver=2021.01.01
+pkgver=2021.04.02
pkgrel=1
pkgdesc="simple screenshot script using maim"
arch=('any')
groups=('therepoclub')
url="https://github.com/The-Repo-Club/i3-maim"
license=('CC BY-NC-SA 4.0')
-depends=('libnotify' 'maim' 'xdg-user-dirs' 'xdotool')
+depends=('libnotify' 'maim' 'xdg-user-dirs' 'xdotool' 'xclip')
source=("${pkgname}-$pkgver.tar.gz::${url}/archive/$pkgver.tar.gz")
-sha256sums=('39d360b31f4228c6f07aa4c5212bf32a37df27f2b118f5e71311d589efa9833e')
+sha256sums=('d6580e29f44c4e688e76de1ff573c97a75380cdcbe0656f22c292e428a8deb4a')
package() {
mkdir -p $pkgdir/usr
diff --git a/i3-maim b/i3-maim
deleted file mode 100755
index d836c5b35057..000000000000
--- a/i3-maim
+++ /dev/null
@@ -1,82 +0,0 @@
-#!/bin/sh
-# /usr/bin/i3-maim
-#
-# simple screenshot-script using maim.
-
-_conf=$HOME/.config/i3/i3-maim.conf
-
-if ! [ -f $_conf ]; then
- echo "maim_dir=$(xdg-user-dir PICTURES)" > $_conf
-fi
-
-source $_conf
-
-if ! [ -d $maim_dir ]; then
- mkdir -p $maim_dir
-fi
-
-if ! [[ -z "$2" ]]; then
- cmd="maim -d $2"
-else
- cmd='maim'
-fi
-
-case "$1" in
- --fullscreen|-f|$NULL)
- $cmd "$maim_dir/$(date +%s).png" &&
- sleep 1 &&
- notify-send "screenshot has been saved in $maim_dir" -a "i3-maim"
- ;;
- --window|-w)
- $cmd -i $(xdotool getactivewindow) "$maim_dir/$(date +%s).png" &&
- sleep 1 &&
- notify-send "screenshot has been saved in $maim_dir" -a "i3-maim"
- ;;
- --select|-s)
- notify-send 'select an area for the screenshot' -a "i3-maim" &
- $cmd -s "$maim_dir/$(date +%s).png" &&
- sleep 1 && notify-send "screenshot has been saved in $maim_dir" -a "i3-maim"
- ;;
- --help|-h)
- echo "
-available options:
--f | --fullscreen full screen
--w | --window active window
--s | --select selection
--h | --help display this information
-
-The -f or -w options can be used with a delay
-by adding the number of seconds, like for example:
-'i3-maim -w 5'
-
-Default option is 'full screen'.
-
-The file destination can be set in ${_conf}.
-Default is $maim_dir
-"
- ;;
- *)
- echo "
-== ! i3-maim: missing or wrong argument ! ==
-
-available options:
--f | --fullscreen full screen
--w | --window active window
--s | --select selection
--h | --help display this information
-
-Default option is 'full screen'.
-
-The -f or -w options can be used with a delay
-by adding the number of seconds, like for example:
-'i3-maim -w 5'
-
-Default option is 'full screen'.
-
-The file destination can be set in ${_conf}.
-Default is $maim_dir
-"
- exit 2
-esac
-
-exit 0