summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2015-09-02 01:44:47 -0600
committerBrian Bidulock2015-09-02 01:44:47 -0600
commit857b66c8432f95a75c9da7a72d24887e5779d2c4 (patch)
tree7deebc935614f83792f7ab88b4421354c879bac9
parentb21621dac8b27293d7811d51804af0273178edfe (diff)
downloadaur-857b66c8432f95a75c9da7a72d24887e5779d2c4.tar.gz
version 2.3-2
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD31
2 files changed, 16 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c1de961c62d0..8caf5ba570ef 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = wmacpi
pkgdesc = Battery monitor dockapp for Window Maker that doesn't depend on HAL
- pkgver = 2.2rc5
- pkgrel = 1
+ pkgver = 2.3
+ pkgrel = 2
url = http://himi.org/wmacpi/
arch = i686
arch = x86_64
license = GPL
depends = libdockapp
- source = http://himi.org/wmacpi/download/wmacpi-2.2rc5.tar.bz2
- md5sums = 9e7a791818cd9646c31e2dbff418ea74
+ source = http://windowmaker.org/dockapps/?download=wmacpi-2.3.tar.gz
+ md5sums = 720bb30d777ec089c029fd79eb4b71e5
pkgname = wmacpi
diff --git a/PKGBUILD b/PKGBUILD
index c290477ee56c..daf8239cace8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,24 @@
-
-# Maintainer: Dennis Gosnell <cdep.illabout@gmail.com>
+# Maintainer: Brian Bidulock <bidulock@openss7.org>
+# Contributor: Dennis Gosnell <cdep.illabout@gmail.com>
pkgname=wmacpi
-pkgver=2.2rc5
-pkgrel=1
+pkgver=2.3
+pkgrel=2
pkgdesc="Battery monitor dockapp for Window Maker that doesn't depend on HAL"
arch=('i686' 'x86_64')
url="http://himi.org/wmacpi/"
license=('GPL')
depends=(libdockapp)
-source=(http://himi.org/wmacpi/download/$pkgname-$pkgver.tar.bz2)
-md5sums=('9e7a791818cd9646c31e2dbff418ea74')
-
+source=("http://windowmaker.org/dockapps/?download=${pkgname}-${pkgver}.tar.gz")
+md5sums=('720bb30d777ec089c029fd79eb4b71e5')
build() {
- cd "$srcdir/$pkgname-$pkgver"
-
- # make sure we don't build the command line `acpi` tool
- sed -i 's/^BUILD_CLI = 1$/#BUILD_CLI = 1/' Makefile
-
- make
+ cd dockapps-*
+ # make sure we don't build the command line `acpi` tool
+ sed -i 's/^BUILD_CLI = 1$/#BUILD_CLI = 1/' Makefile
+ make
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
-
- # make sure we install the man pages in the right place
- sed -i 's|man/man1|share/man/man1|' Makefile
-
- make install PREFIX="$pkgdir/usr/"
+ cd dockapps-*
+ make install PREFIX="$pkgdir/usr/"
}