summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2015-06-10 22:29:12 -0600
committerBrian Bidulock2015-06-10 22:29:12 -0600
commitb21621dac8b27293d7811d51804af0273178edfe (patch)
tree725213991ef4b50947a2f05070f8fc331ecf73c5
downloadaur-b21621dac8b27293d7811d51804af0273178edfe.tar.gz
initial version
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD31
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c1de961c62d0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = wmacpi
+ pkgdesc = Battery monitor dockapp for Window Maker that doesn't depend on HAL
+ pkgver = 2.2rc5
+ pkgrel = 1
+ url = http://himi.org/wmacpi/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = libdockapp
+ source = http://himi.org/wmacpi/download/wmacpi-2.2rc5.tar.bz2
+ md5sums = 9e7a791818cd9646c31e2dbff418ea74
+
+pkgname = wmacpi
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c290477ee56c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+
+# Maintainer: Dennis Gosnell <cdep.illabout@gmail.com>
+pkgname=wmacpi
+pkgver=2.2rc5
+pkgrel=1
+pkgdesc="Battery monitor dockapp for Window Maker that doesn't depend on HAL"
+arch=('i686' 'x86_64')
+url="http://himi.org/wmacpi/"
+license=('GPL')
+depends=(libdockapp)
+source=(http://himi.org/wmacpi/download/$pkgname-$pkgver.tar.bz2)
+md5sums=('9e7a791818cd9646c31e2dbff418ea74')
+
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ # make sure we don't build the command line `acpi` tool
+ sed -i 's/^BUILD_CLI = 1$/#BUILD_CLI = 1/' Makefile
+
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ # make sure we install the man pages in the right place
+ sed -i 's|man/man1|share/man/man1|' Makefile
+
+ make install PREFIX="$pkgdir/usr/"
+}