summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2013-04-11 11:05:46 -0600
committerBrian Bidulock2015-06-10 22:32:54 -0600
commit4c4e87a7d1e4b2504fb9aa2ed96ecbedc65c8ed8 (patch)
treeace9b299ab36f7ab1cc30f786b952a7abf0e9375
parent13e80ea063b384a963f6e371c032ceb2fe17eb90 (diff)
downloadaur-4c4e87a7d1e4b2504fb9aa2ed96ecbedc65c8ed8.tar.gz
version 0.4.27-2
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD21
2 files changed, 8 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bb8da5a8577c..9ae19cc0f657 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,16 @@
pkgbase = wmbiff
pkgdesc = WindowMaker dock app that displays the number of read and unread messages in up to five mailboxes.
pkgver = 0.4.27
- pkgrel = 4
+ pkgrel = 2
url = http://wmbiff.sourceforge.net/
arch = i686
arch = x86_64
license = GPL
depends = libxpm
- depends = gnutls
+ depends = libgcrypt
optdepends = ruby: to run security.debian.rb
source = http://downloads.sourceforge.net/wmbiff/wmbiff-0.4.27.tar.gz
- source = libgnutls-config
- source = gnutls.patch
md5sums = 50466b6e4a143cf4e55546b34d5792e6
- md5sums = e549721cfa4f39956f1f8c8c612e4e5e
- md5sums = 74ec98339fde3534ed5a2761c84e8ea6
pkgname = wmbiff
diff --git a/PKGBUILD b/PKGBUILD
index ac5ba6a7c8a5..754612864d36 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,31 +2,22 @@
pkgname=wmbiff
pkgver=0.4.27
arch=('i686' 'x86_64')
-pkgrel=4
+pkgrel=2
pkgdesc="WindowMaker dock app that displays the number of read and unread messages in up to five mailboxes."
url="http://wmbiff.sourceforge.net/"
license=("GPL")
-depends=('libxpm' 'gnutls')
+depends=('libxpm' 'libgcrypt')
optdepends=('ruby: to run security.debian.rb')
-source=("http://downloads.sourceforge.net/wmbiff/wmbiff-0.4.27.tar.gz"
- "libgnutls-config"
- "gnutls.patch")
-md5sums=('50466b6e4a143cf4e55546b34d5792e6'
- 'e549721cfa4f39956f1f8c8c612e4e5e'
- '74ec98339fde3534ed5a2761c84e8ea6')
-
-prepare() {
- cd "$srcdir/$pkgname-$pkgver"
- patch -Np1 -b -z .orig -i ../gnutls.patch
-}
+source=("http://downloads.sourceforge.net/wmbiff/wmbiff-0.4.27.tar.gz")
+md5sums=('50466b6e4a143cf4e55546b34d5792e6')
build() {
cd "$srcdir/$pkgname-$pkgver"
- ./configure LIBGNUTLS_CONFIG="$srcdir/libgnutls-config" --prefix=/usr --mandir=/usr/share/man
+ ./configure --prefix=/usr --mandir=/usr/share/man || return 1
make
}
-
package() {
cd "$srcdir/$pkgname-$pkgver"
make DESTDIR="$pkgdir" install
}
+