summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2014-07-03 16:57:53 -0600
committerBrian Bidulock2015-06-10 22:32:55 -0600
commitc5447e9080a886a5576ad48eeadf55a4c89a4255 (patch)
tree741e8a2a611c85d44ab0934fde4e005a95e616ea
parent46ac24e30d34e2186947141a6ae79bed04b60579 (diff)
downloadaur-c5447e9080a886a5576ad48eeadf55a4c89a4255.tar.gz
version 0.4.27-4
-rw-r--r--.AURINFO17
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD21
3 files changed, 38 insertions, 8 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..3282730cfaa4
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,17 @@
+pkgbase = wmbiff
+ pkgdesc = WindowMaker dock app that displays the number of read and unread messages in up to five mailboxes.
+ pkgver = 0.4.27
+ pkgrel = 4
+ url = http://wmbiff.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = libxpm
+ depends = gnutls
+ optdepends = ruby: to run security.debian.rb
+ source = http://downloads.sourceforge.net/wmbiff/wmbiff-0.4.27.tar.gz
+ source = libgnutls-config
+ source = gnutls.patch
+
+pkgname = wmbiff
+
diff --git a/.SRCINFO b/.SRCINFO
index 110edb51983d..bb8da5a8577c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,20 @@
pkgbase = wmbiff
pkgdesc = WindowMaker dock app that displays the number of read and unread messages in up to five mailboxes.
pkgver = 0.4.27
- pkgrel = 3
+ pkgrel = 4
url = http://wmbiff.sourceforge.net/
arch = i686
arch = x86_64
license = GPL
depends = libxpm
- depends = libgcrypt
+ depends = gnutls
optdepends = ruby: to run security.debian.rb
source = http://downloads.sourceforge.net/wmbiff/wmbiff-0.4.27.tar.gz
+ source = libgnutls-config
+ source = gnutls.patch
md5sums = 50466b6e4a143cf4e55546b34d5792e6
+ md5sums = e549721cfa4f39956f1f8c8c612e4e5e
+ md5sums = 74ec98339fde3534ed5a2761c84e8ea6
pkgname = wmbiff
diff --git a/PKGBUILD b/PKGBUILD
index 72790776f730..ac5ba6a7c8a5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,22 +2,31 @@
pkgname=wmbiff
pkgver=0.4.27
arch=('i686' 'x86_64')
-pkgrel=3
+pkgrel=4
pkgdesc="WindowMaker dock app that displays the number of read and unread messages in up to five mailboxes."
url="http://wmbiff.sourceforge.net/"
license=("GPL")
-depends=('libxpm' 'libgcrypt')
+depends=('libxpm' 'gnutls')
optdepends=('ruby: to run security.debian.rb')
-source=("http://downloads.sourceforge.net/wmbiff/wmbiff-0.4.27.tar.gz")
-md5sums=('50466b6e4a143cf4e55546b34d5792e6')
+source=("http://downloads.sourceforge.net/wmbiff/wmbiff-0.4.27.tar.gz"
+ "libgnutls-config"
+ "gnutls.patch")
+md5sums=('50466b6e4a143cf4e55546b34d5792e6'
+ 'e549721cfa4f39956f1f8c8c612e4e5e'
+ '74ec98339fde3534ed5a2761c84e8ea6')
+
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+ patch -Np1 -b -z .orig -i ../gnutls.patch
+}
build() {
cd "$srcdir/$pkgname-$pkgver"
- ./configure --prefix=/usr --mandir=/usr/share/man || return 1
+ ./configure LIBGNUTLS_CONFIG="$srcdir/libgnutls-config" --prefix=/usr --mandir=/usr/share/man
make
}
+
package() {
cd "$srcdir/$pkgname-$pkgver"
make DESTDIR="$pkgdir" install
}
-