summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2015-12-01 17:45:45 -0700
committerBrian Bidulock2015-12-01 17:45:45 -0700
commitdadba4779568b785ea89265274a3681ba656d157 (patch)
tree1092325c9f683bf7d3a290c923c751a1d8642c8f
parentc5447e9080a886a5576ad48eeadf55a4c89a4255 (diff)
downloadaur-dadba4779568b785ea89265274a3681ba656d157.tar.gz
version 0.4.28.20151026-1
-rw-r--r--.AURINFO17
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD22
-rw-r--r--gnutls.patch53
-rwxr-xr-xlibgnutls-config8
5 files changed, 15 insertions, 99 deletions
diff --git a/.AURINFO b/.AURINFO
deleted file mode 100644
index 3282730cfaa4..000000000000
--- a/.AURINFO
+++ /dev/null
@@ -1,17 +0,0 @@
-pkgbase = wmbiff
- pkgdesc = WindowMaker dock app that displays the number of read and unread messages in up to five mailboxes.
- pkgver = 0.4.27
- pkgrel = 4
- url = http://wmbiff.sourceforge.net/
- arch = i686
- arch = x86_64
- license = GPL
- depends = libxpm
- depends = gnutls
- optdepends = ruby: to run security.debian.rb
- source = http://downloads.sourceforge.net/wmbiff/wmbiff-0.4.27.tar.gz
- source = libgnutls-config
- source = gnutls.patch
-
-pkgname = wmbiff
-
diff --git a/.SRCINFO b/.SRCINFO
index bb8da5a8577c..5dc47bfb1254 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v7
+# Wed Dec 2 00:45:23 UTC 2015
pkgbase = wmbiff
pkgdesc = WindowMaker dock app that displays the number of read and unread messages in up to five mailboxes.
- pkgver = 0.4.27
- pkgrel = 4
+ pkgver = 0.4.28.20151026
+ pkgrel = 1
url = http://wmbiff.sourceforge.net/
arch = i686
arch = x86_64
@@ -9,12 +11,8 @@ pkgbase = wmbiff
depends = libxpm
depends = gnutls
optdepends = ruby: to run security.debian.rb
- source = http://downloads.sourceforge.net/wmbiff/wmbiff-0.4.27.tar.gz
- source = libgnutls-config
- source = gnutls.patch
- md5sums = 50466b6e4a143cf4e55546b34d5792e6
- md5sums = e549721cfa4f39956f1f8c8c612e4e5e
- md5sums = 74ec98339fde3534ed5a2761c84e8ea6
+ source = wmbiff-0.4.28.20151026.tar.gz::http://windowmaker.org/dockapps/?download=wmbiff-0.4.28+20151026.tar.gz
+ md5sums = SKIP
pkgname = wmbiff
diff --git a/PKGBUILD b/PKGBUILD
index ac5ba6a7c8a5..ba8d7ae43d9f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,28 @@
# Maintainer: Brian Bidulock <bidulock@openss7.org>
pkgname=wmbiff
-pkgver=0.4.27
+pkgver=0.4.28.20151026
arch=('i686' 'x86_64')
-pkgrel=4
+pkgrel=1
pkgdesc="WindowMaker dock app that displays the number of read and unread messages in up to five mailboxes."
url="http://wmbiff.sourceforge.net/"
license=("GPL")
depends=('libxpm' 'gnutls')
optdepends=('ruby: to run security.debian.rb')
-source=("http://downloads.sourceforge.net/wmbiff/wmbiff-0.4.27.tar.gz"
- "libgnutls-config"
- "gnutls.patch")
-md5sums=('50466b6e4a143cf4e55546b34d5792e6'
- 'e549721cfa4f39956f1f8c8c612e4e5e'
- '74ec98339fde3534ed5a2761c84e8ea6')
+source=("${pkgname}-${pkgver}.tar.gz::http://windowmaker.org/dockapps/?download=wmbiff-0.4.28+20151026.tar.gz")
+md5sums=('SKIP')
prepare() {
- cd "$srcdir/$pkgname-$pkgver"
- patch -Np1 -b -z .orig -i ../gnutls.patch
+ cd dockapps-*
+ autoreconf -fiv
}
build() {
- cd "$srcdir/$pkgname-$pkgver"
- ./configure LIBGNUTLS_CONFIG="$srcdir/libgnutls-config" --prefix=/usr --mandir=/usr/share/man
+ cd dockapps-*
+ ./configure --prefix=/usr --mandir=/usr/share/man
make
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd dockapps-*
make DESTDIR="$pkgdir" install
}
diff --git a/gnutls.patch b/gnutls.patch
deleted file mode 100644
index bcc0bcafcd7f..000000000000
--- a/gnutls.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-diff -up wmbiff-0.4.27/wmbiff/gnutls-common.c.orig wmbiff-0.4.27/wmbiff/gnutls-common.c
---- wmbiff-0.4.27/wmbiff/gnutls-common.c.orig 2014-07-03 16:45:39.000000000 -0600
-+++ wmbiff-0.4.27/wmbiff/gnutls-common.c 2014-07-03 16:51:11.000000000 -0600
-@@ -4,7 +4,6 @@
- #include <stdlib.h>
- #include <string.h>
- #include <gnutls/gnutls.h>
--#include <gnutls/extra.h>
- #include <gnutls/x509.h>
- #include <gnutls/openpgp.h>
- #include <time.h>
-@@ -335,10 +334,15 @@ void print_openpgp_info(gnutls_session s
- void print_cert_vrfy(gnutls_session session)
- {
-
-- int status;
-- status = gnutls_certificate_verify_peers(session);
-+ int status, retval;
-+ retval = gnutls_certificate_verify_peers2(session, &status);
- printf("\n");
-
-+ if (retval != GNUTLS_E_SUCCESS) {
-+ printf("- Could not verify certificate (err: %s)\n",
-+ gnutls_strerror(retval));
-+ return;
-+ }
- if (status == GNUTLS_E_NO_CERTIFICATE_FOUND) {
- printf("- Peer did not send any certificate.\n");
- return;
-@@ -637,8 +641,6 @@ void parse_comp(char **comp, int ncomp,
- comp_priority[j++] = GNUTLS_COMP_NULL;
- if (strncasecmp(comp[i], "ZLI", 3) == 0)
- comp_priority[j++] = GNUTLS_COMP_ZLIB;
-- if (strncasecmp(comp[i], "LZO", 3) == 0)
-- comp_priority[j++] = GNUTLS_COMP_LZO;
- }
- comp_priority[j] = 0;
- }
-diff -up wmbiff-0.4.27/wmbiff/tlsComm.c.orig wmbiff-0.4.27/wmbiff/tlsComm.c
---- wmbiff-0.4.27/wmbiff/tlsComm.c.orig 2014-07-03 16:41:16.000000000 -0600
-+++ wmbiff-0.4.27/wmbiff/tlsComm.c 2014-07-03 16:44:55.000000000 -0600
-@@ -419,8 +419,9 @@ tls_check_certificate(struct connection_
- bad_certificate(scs, "Unable to get certificate from peer.\n");
- return; /* bad_cert will exit if -skip-certificate-check was not given */
- }
-- certstat = gnutls_certificate_verify_peers(scs->tls_state);
-- if (certstat == GNUTLS_E_NO_CERTIFICATE_FOUND) {
-+ if (gnutls_certificate_verify_peers2(scs->tls_state, &certstat) != GNUTLS_E_SUCCESS) {
-+ bad_certificate(scs, "cannot verify certificate.\n");
-+ } else if (certstat == GNUTLS_E_NO_CERTIFICATE_FOUND) {
- bad_certificate(scs, "server presented no certificate.\n");
- #ifdef GNUTLS_CERT_CORRUPTED
- } else if (certstat & GNUTLS_CERT_CORRUPTED) {
diff --git a/libgnutls-config b/libgnutls-config
deleted file mode 100755
index 8c673e4443ac..000000000000
--- a/libgnutls-config
+++ /dev/null
@@ -1,8 +0,0 @@
-#!/bin/sh
-
-if [ "$1" = "--version" ]; then
- shift
- pkg-config gnutls --modversion "$@"
-else
- pkg-config gnutls "$@"
-fi