summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2015-06-10 22:43:20 -0600
committerBrian Bidulock2015-06-10 22:43:20 -0600
commite5b10cf9002f19ff3af42fa641fb7b2278a077eb (patch)
tree1415c4d3af2cbfeeb68b1f19ecbf2126d7a164df
downloadaur-e5b10cf9002f19ff3af42fa641fb7b2278a077eb.tar.gz
initial version
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD29
-rw-r--r--wmcube-0.98.tar.gzbin0 -> 38310 bytes
-rw-r--r--wmcube.patch54
4 files changed, 99 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eb4376f2ccf4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = wmcube
+ pkgdesc = 3D objects tumbling about representing CPU load
+ pkgver = 0.98
+ pkgrel = 3
+ url = http://web.archive.org/web/20121116163211/http://dockapps.windowmaker.org/file.php/id/162
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = libxpm
+ source = wmcube-0.98.tar.gz
+ source = wmcube.patch
+ md5sums = efc6f484c53f0a98a76925a6e1a74cd3
+ md5sums = 83d0ba27b2122d248123c677e2713e07
+
+pkgname = wmcube
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3a2fdaf6bf16
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Brian Bidulock <bidulock@openss7.org>
+# Contributor: Mario Blättermann <mariobl@gnome.org>
+
+pkgname=wmcube
+pkgver=0.98
+pkgrel=3
+pkgdesc="3D objects tumbling about representing CPU load"
+arch=('i686' 'x86_64')
+#url="http://dockapps.windowmaker.org/file.php/id/162"
+url="http://web.archive.org/web/20121116163211/http://dockapps.windowmaker.org/file.php/id/162"
+license=('GPL')
+depends=('libxpm')
+#source=("http://dockapps.windowmaker.org/download.php/id/222/$pkgname-$pkgver.tar.gz"
+# "$pkgname.patch")
+source=("$pkgname-$pkgver.tar.gz"
+ "$pkgname.patch")
+md5sums=('efc6f484c53f0a98a76925a6e1a74cd3'
+ '83d0ba27b2122d248123c677e2713e07')
+
+build() {
+ cd "$srcdir/$pkgname"
+ patch -Np2 -b -z .orig -i "$srcdir/$pkgname.patch"
+ cd "$pkgname"
+ make
+}
+package() {
+ cd "$srcdir/$pkgname/$pkgname"
+ install -Dm755 $pkgname "$pkgdir/usr/bin/$pkgname"
+}
diff --git a/wmcube-0.98.tar.gz b/wmcube-0.98.tar.gz
new file mode 100644
index 000000000000..4a0370cdcdd6
--- /dev/null
+++ b/wmcube-0.98.tar.gz
Binary files differ
diff --git a/wmcube.patch b/wmcube.patch
new file mode 100644
index 000000000000..694ee818951c
--- /dev/null
+++ b/wmcube.patch
@@ -0,0 +1,54 @@
+diff -up src/wmcube/wmcube/wmcube.c.orig src/wmcube/wmcube/wmcube.c
+--- src/wmcube/wmcube/wmcube.c.orig 2000-10-23 14:11:47.000000000 -0600
++++ src/wmcube/wmcube/wmcube.c 2013-09-04 02:16:37.000000000 -0600
+@@ -132,7 +132,6 @@ int main(int argc, char **argv)
+ int j, i = 0, rot_speed = 0, cpu_usage = 0, rot_step = 1;
+ long screen_speed = 10000; // microseconds between screen updates (approx.)
+ long cpu_update = 490000; // microseconds between cpu update (approx.)
+- int but_stat = -1;
+ int loop = 0;
+ XEvent Event;
+
+@@ -289,7 +288,6 @@ int main(int argc, char **argv)
+ break;
+ case ButtonPress:
+ j = CheckMouseRegion(Event.xbutton.x, Event.xbutton.y);
+- but_stat = j;
+
+ break;
+ case ButtonRelease:
+@@ -682,7 +680,7 @@ void sortz(int nofelements) { // Inser
+
+ while ((i > -1) && (temparr[i] > key)) {
+ temparr[i+1] = temparr[i];
+- zorder[i+1] = zorder[i--];
++ zorder[i+1] = zorder[i]; i--;
+ }
+
+ zorder[i+1] = k;
+@@ -904,7 +902,7 @@ int loadobj(char *filename) {
+
+ FILE *fp;
+ char tmp[64] = {""};
+- int i = 0, counter = 1;
++ int i = 0;
+
+ //printf("\nLoading file %s...",filename); fflush(stdout);
+
+@@ -922,7 +920,6 @@ int loadobj(char *filename) {
+ }
+
+ fscanf(fp,"%s",tmp);
+- counter = atoi(tmp);
+
+ while ((strcmp(tmp,"WMCUBE_LINES") != 0) && (strcmp(tmp,"WMCUBE_PLANES") != 0)) {
+
+@@ -956,7 +953,7 @@ int loadobj(char *filename) {
+ while (1) {
+
+ cline = (int *)realloc(cline,(i+2)*sizeof(int)); mem_alloc_error(cline);
+- fscanf(fp,"%d %d",&cline[i++],&cline[i++]);
++ fscanf(fp,"%d %d",&cline[i],&cline[i+1]); i += 2;
+ //printf("\n%d %d",cline[i-2],cline[i-1]);
+ if (feof(fp)) break;
+