summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarco Wang2020-02-25 13:14:54 +0800
committerMarco Wang2020-02-25 13:14:54 +0800
commit2da1b7f50fb47485d6777dd6ebee149e2a5460e6 (patch)
treeb7fd0b6f3baf4ac73256e49510e99123fe71144b
downloadaur-2da1b7f50fb47485d6777dd6ebee149e2a5460e6.tar.gz
add PKGBUILD, wmderland.install and .SRCINFO
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD35
-rw-r--r--wmderland.install6
3 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fe48e3b92fc4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = wmderland-git
+ pkgdesc = X11 tiling window manager using space partitioning trees
+ pkgver = 1.0.2
+ pkgrel = 1
+ url = https://github.com/aesophor/wmderland
+ install = wmderland.install
+ arch = x86_64
+ license = MIT
+ makedepends = gcc>=6.0
+ makedepends = cmake>=3.9
+ depends = libx11
+ source = git://github.com/aesophor/wmderland.git
+ sha256sums = SKIP
+
+pkgname = wmderland-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..844ed8902dcf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Marco Wang <m.aesophor@gmail.com>
+
+pkgname=wmderland-git
+_pkgname=wmderland
+pkgver=1.0.2
+pkgrel=1
+pkgdesc='X11 tiling window manager using space partitioning trees'
+arch=('x86_64')
+url="https://github.com/aesophor/wmderland"
+license=('MIT')
+depends=('libx11')
+makedepends=('gcc>=6.0' 'cmake>=3.9')
+install=${_pkgname}.install
+source=('git://github.com/aesophor/wmderland.git')
+sha256sums=('SKIP')
+
+build() {
+ cd ${_pkgname}/
+ ./build.sh
+}
+
+package() {
+ # Install wmderland.
+ cd ${_pkgname}/build/
+ make DESTDIR="${pkgdir}/" PREFIX="/usr/local/" install
+
+ # Install wmderlandc (ipc client).
+ cd ../ipc-client/build/
+ make DESTDIR="${pkgdir}/" PREFIX="/usr/local/" install
+
+ # Install example config file.
+ cd ../../
+ mkdir -p "${pkgdir}/etc/xdg/wmderland/"
+ install -D -m644 example/* "${pkgdir}/etc/xdg/wmderland/"
+}
diff --git a/wmderland.install b/wmderland.install
new file mode 100644
index 000000000000..a1d9aa761296
--- /dev/null
+++ b/wmderland.install
@@ -0,0 +1,6 @@
+post_install() {
+ cat << EOF
+==> IMPORTANT: Make sure you have a config file in ~/.config/wmderland/config
+==> An example config file has been placed at /etc/xdg/wmderland/config
+EOF
+}