summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRishabh Das2022-08-19 11:05:41 +0530
committerRishabh Das2022-08-19 11:05:41 +0530
commitcd5b160ab44ff70b003b5798e23c26cf0a4148d5 (patch)
treebd5b5d0076fd46c0d994c7224a9e52adea4c13d7
downloadaur-wmenu-git.tar.gz
init
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD30
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..87026db9b686
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = wmenu-git
+ pkgdesc = An efficient dynamic menu for Sway and wlroots based Wayland compositors
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://git.sr.ht/~adnano/wmenu
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = meson
+ makedepends = ninja
+ makedepends = scdoc
+ depends = cairo
+ depends = pango
+ depends = wayland
+ depends = libxkbcommon
+ provides = wmenu
+ conflicts = wmenu
+ source = git+https://git.sr.ht/~adnano/wmenu
+ sha256sums = SKIP
+
+pkgname = wmenu-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..005536f75fbc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Rishabh Das <rdas@tutanota.com>
+pkgname='wmenu-git'
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="An efficient dynamic menu for Sway and wlroots based Wayland compositors"
+arch=('x86_64')
+url="https://git.sr.ht/~adnano/wmenu"
+license=('MIT')
+depends=('cairo' 'pango' 'wayland' 'libxkbcommon')
+makedepends=('git' 'meson' 'ninja' 'scdoc')
+provides=('wmenu')
+conflicts=('wmenu')
+source=("git+$url")
+sha256sums=('SKIP')
+
+pkgver() {
+ git -C wmenu describe --abbrev=10 | sed 's/-/+/; s/-/./'
+}
+
+build() {
+ cd wmenu
+ meson --prefix="/usr" --buildtype=release -Db_lto=true build
+ ninja -C build
+}
+
+package() {
+ cd wmenu
+ DESTDIR="${pkgdir}/" ninja -C build install
+ install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/wmenu/LICENSE"
+}