summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrett Cornwall2024-01-26 09:31:53 -0800
committerBrett Cornwall2024-01-26 09:31:53 -0800
commitba778a011fce0bc4f8be2d7084a08664a150737a (patch)
treed5d950d33e0e39bf1dcdbafceac9bf0d885c5a51
downloadaur-ba778a011fce0bc4f8be2d7084a08664a150737a.tar.gz
upgpkg: 0.1.6-1
Imported from AUR as sway will use this as default in the next release
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD39
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f9ef12524904
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = wmenu
+ pkgdesc = Efficient dynamic menu for Wayland and wlroots based Wayland compositors
+ pkgver = 0.1.6
+ pkgrel = 1
+ url = https://git.sr.ht/~adnano/wmenu
+ arch = x86_64
+ license = MIT
+ makedepends = meson
+ makedepends = ninja
+ makedepends = scdoc
+ makedepends = wayland-protocols
+ depends = libcairo.so
+ depends = libxkbcommon.so
+ depends = libpango-1.0.so
+ depends = libwayland-client.so
+ source = wmenu-0.1.6.tar.gz::https://git.sr.ht/~adnano/wmenu/archive/0.1.6.tar.gz
+ b2sums = f624773e29c751cb0d890d428482019bab35af1d3f540a53233307d30955dd5936a3eab483be7dac471aab6a85a4cd1953d9a75f095130316a13f96684d52477
+
+pkgname = wmenu
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cd14fcb4da53
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Brett Cornwall <ainola@archlinux.org>
+# Contributor: nullcoder
+
+pkgname=wmenu
+pkgver=0.1.6
+pkgrel=1
+pkgdesc="Efficient dynamic menu for Wayland and wlroots based Wayland compositors"
+arch=('x86_64')
+url="https://git.sr.ht/~adnano/wmenu"
+license=('MIT')
+makedepends=(
+ 'meson'
+ 'ninja'
+ 'scdoc'
+ 'wayland-protocols'
+)
+depends=(
+ 'libcairo.so'
+ 'libxkbcommon.so'
+ 'libpango-1.0.so'
+ 'libwayland-client.so'
+)
+source=(
+ "$pkgname-$pkgver.tar.gz::https://git.sr.ht/~adnano/wmenu/archive/$pkgver.tar.gz"
+)
+b2sums=('f624773e29c751cb0d890d428482019bab35af1d3f540a53233307d30955dd5936a3eab483be7dac471aab6a85a4cd1953d9a75f095130316a13f96684d52477')
+
+build() {
+ cd "$pkgname-$pkgver"
+ arch-meson build
+ ninja -C build
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ DESTDIR="$pkgdir" ninja -C build install
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+