summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYichao Zhou2015-12-24 23:51:29 -0800
committerYichao Zhou2015-12-24 23:51:29 -0800
commitd99cde1574d5e89f410c12682e27754ade8998c4 (patch)
tree1df66778655f2ec6da2a9c3978258691bf69d867
downloadaur-d99cde1574d5e89f410c12682e27754ade8998c4.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD30
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3730bafad621
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Fri Dec 25 07:51:22 UTC 2015
+pkgbase = wmidump-git
+ pkgdesc = Dump WMI informations from ACPI tables
+ pkgver = r13
+ pkgrel = 1
+ url = https://github.com/iksaif/wmidump
+ arch = i686
+ arch = x86_64
+ license = unknown
+ makedepends = git
+ provides = wmidump
+ conflicts = wmidump
+ source = wmidump-git::git+http://github.com/iksaif/wmidump
+ sha256sums = SKIP
+
+pkgname = wmidump-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cd592244ac20
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Caleb Johnson <me@calebj.io>
+_pkgname=wmidump
+pkgname=${_pkgname}-git
+provides=wmidump
+pkgrel=1
+pkgver=r13
+conflicts=wmidump
+pkgdesc="Dump WMI informations from ACPI tables"
+arch=('i686' 'x86_64')
+url="https://github.com/iksaif/wmidump"
+license=unknown
+depends=()
+makedepends=(git)
+source=("${pkgname}"::'git+http://github.com/iksaif/wmidump')
+sha256sums=('SKIP')
+
+pkgver(){
+ cd "${srcdir}/${pkgname}"
+ echo r`git rev-list --count HEAD`
+}
+
+build(){
+ cd "${srcdir}/${pkgname}"
+ make
+}
+
+package(){
+ cd "${srcdir}/${pkgname}"
+ install -Dm755 ${_pkgname} "${pkgdir}/usr/bin/${_pkgname}"
+}