summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoraksr2018-05-19 23:00:29 +0200
committeraksr2018-05-19 23:00:29 +0200
commitc5d16ea99987bf47efa7eab1ac442d903ddf98ed (patch)
tree98fa97382ea5e3270a4ec7ea2163c2ce08dffde4
downloadaur-c5d16ea99987bf47efa7eab1ac442d903ddf98ed.tar.gz
Start.
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD56
2 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d7dc15dfa4c2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+# Generated by mksrcinfo v8
+# Sat May 19 21:00:28 UTC 2018
+pkgbase = wmii-git
+ pkgdesc = A dynamic window manager for X11.
+ pkgver = r2818.a0b47f29
+ pkgrel = 1
+ url = https://github.com/0intro/wmii
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ depends = libx11
+ depends = libxinerama
+ depends = libxrandr
+ optdepends = dash: for use of the default wmiirc configs
+ optdepends = libxft: for anti-aliased font support
+ optdepends = xorg-xmessage: for use of the default wmiirc configs
+ optdepends = plan9port: for use of the alternative plan9port wmiirc
+ optdepends = python2: for use of the alternative Python wmiirc
+ optdepends = ruby-rumai: for use of the alternative Ruby wmiirc
+ conflicts = wmii
+ conflicts = wmii-hg
+ source = wmii-git::git+https://github.com/0intro/wmii
+ md5sums = SKIP
+
+pkgname = wmii-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..77e37e968657
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,56 @@
+# Maintainer: aksr <aksr at t-com dot me>
+pkgname=wmii-git
+pkgver=r2818.a0b47f29
+pkgrel=1
+epoch=
+pkgdesc="A dynamic window manager for X11."
+arch=('i686' 'x86_64')
+url="https://github.com/0intro/wmii"
+license=('MIT')
+categories=()
+groups=()
+depends=('libx11' 'libxinerama' 'libxrandr')
+makedepends=('git')
+optdepends=(
+ 'dash: for use of the default wmiirc configs'
+ 'libxft: for anti-aliased font support'
+ 'xorg-xmessage: for use of the default wmiirc configs'
+ 'plan9port: for use of the alternative plan9port wmiirc'
+ 'python2: for use of the alternative Python wmiirc'
+ 'ruby-rumai: for use of the alternative Ruby wmiirc'
+)
+checkdepends=()
+provides=()
+conflicts=("${pkgname%-*}" "${pkgname%-*}-hg")
+replaces=()
+backup=()
+options=()
+changelog=
+install=
+source=("$pkgname::git+$url")
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$srcdir/$pkgname"
+ sed -i 's/README/&.md/' Makefile
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ make PREFIX=/usr
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ make DESTDIR="$pkgdir/" PREFIX=/usr install
+ install -Dm644 README.md $pkgdir/usr/share/doc/${pkgname%-*}/README.md
+ install -Dm644 LICENSE $pkgdir/usr/share/licenses/${pkgname%-*}/LICENSE
+ rm $pkgdir/usr/share/doc/wmii/LICENSE
+}
+