summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoraksr2023-01-29 19:16:48 +0100
committeraksr2023-01-29 19:16:48 +0100
commiteb8b929724828ce758cb9e5f59c6296383cfe133 (patch)
tree759a16542328d0c7eca82b66b71e4d002f9b81c3
parent985eb0b7a061facdc9e25a0b603bf762bcd4f51a (diff)
downloadaur-eb8b929724828ce758cb9e5f59c6296383cfe133.tar.gz
...
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD56
2 files changed, 26 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5867005b2156..8ac7cfb1bbca 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Mon May 21 05:30:42 UTC 2018
pkgbase = wmii-git
pkgdesc = A dynamic window manager for X11.
- pkgver = r2820.489c9e47
+ pkgver = r2825.ff120c7f
pkgrel = 1
url = https://github.com/0intro/wmii
arch = i686
@@ -24,4 +22,3 @@ pkgbase = wmii-git
md5sums = SKIP
pkgname = wmii-git
-
diff --git a/PKGBUILD b/PKGBUILD
index c9715e2691b4..ecebdaede86b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,51 +1,45 @@
# Maintainer: aksr <aksr at t-com dot me>
pkgname=wmii-git
-pkgver=r2820.489c9e47
+pkgver=r2825.ff120c7f
pkgrel=1
epoch=
-pkgdesc="A dynamic window manager for X11."
+pkgdesc='A dynamic window manager for X11.'
arch=('i686' 'x86_64')
-url="https://github.com/0intro/wmii"
-license=('MIT')
-categories=()
-groups=()
+url='https://github.com/0intro/wmii'
+license=(MIT)
depends=('libx11' 'libxinerama' 'libxrandr')
-makedepends=('git')
+makedepends=(git)
optdepends=(
- 'dash: for use of the default wmiirc configs'
- 'libxft: for anti-aliased font support'
- 'xorg-xmessage: for use of the default wmiirc configs'
- 'plan9port: for use of the alternative plan9port wmiirc'
- 'python2: for use of the alternative Python wmiirc'
- 'ruby-rumai: for use of the alternative Ruby wmiirc'
+ 'dash: for use of the default wmiirc configs'
+ 'libxft: for anti-aliased font support'
+ 'xorg-xmessage: for use of the default wmiirc configs'
+ 'plan9port: for use of the alternative plan9port wmiirc'
+ 'python2: for use of the alternative Python wmiirc'
+ 'ruby-rumai: for use of the alternative Ruby wmiirc'
)
-checkdepends=()
-provides=()
conflicts=("${pkgname%-*}" "${pkgname%-*}-hg")
-replaces=()
-backup=()
-options=()
-changelog=
-install=
source=("$pkgname::git+$url")
-noextract=()
md5sums=('SKIP')
+prepare() {
+ cd "$srcdir/$pkgname"
+ sed -i 's/egrep/grep -E/g' Makefile util/link
+ sed -i 's/-O0/-O2/g' mk/gcc.mk
+}
pkgver() {
- cd "$srcdir/$pkgname"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd "$srcdir/$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
- cd "$srcdir/$pkgname"
- make PREFIX=/usr
+ cd "$srcdir/$pkgname"
+ make PREFIX=/usr
}
package() {
- cd "$srcdir/$pkgname"
- make DESTDIR="$pkgdir/" PREFIX=/usr install
- install -Dm644 README.md $pkgdir/usr/share/doc/${pkgname%-*}/README.md
- install -Dm644 LICENSE $pkgdir/usr/share/licenses/${pkgname%-*}/LICENSE
- rm $pkgdir/usr/share/doc/wmii/LICENSE
+ cd "$srcdir/$pkgname"
+ make DESTDIR="$pkgdir/" PREFIX=/usr install
+ install -Dm644 README.md $pkgdir/usr/share/doc/${pkgname%-*}/README.md
+ install -Dm644 LICENSE $pkgdir/usr/share/licenses/${pkgname%-*}/LICENSE
+ rm $pkgdir/usr/share/doc/wmii/LICENSE
}
-