summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2013-03-26 03:55:02 -0600
committerBrian Bidulock2015-06-10 23:01:39 -0600
commitd1ab290def1b23cb54883b74d515b57a46030ded (patch)
treef888d2bd716eee30059127371543e29d29adfa48
parent24603d456b4a1fb6377b9a70663dbee689da28ef (diff)
downloadaur-d1ab290def1b23cb54883b74d515b57a46030ded.tar.gz
version 1.5-1
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD16
-rw-r--r--wmmixer-1.5.tar.gzbin0 -> 27483 bytes
-rw-r--r--wmmixer.patch74
4 files changed, 88 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bab95218b838..45b8ed142a0a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
pkgbase = wmmixer
pkgdesc = A mixer application written for the WindowMaker dock.
- pkgver = 1.7+20141005
+ pkgver = 1.5
pkgrel = 1
- url = http://windowmaker.org/dockapps/?name=wmmixer
+ url = http://dockapps.windowmaker.org/file.php/id/101
arch = i686
arch = x86_64
license = GPL
- depends = libxpm
- source = wmmixer-1.7+20141005.tar.gz::http://windowmaker.org/dockapps/?download=wmmixer-1.7+20141005.tar.gz
- md5sums = SKIP
+ source = wmmixer-1.5.tar.gz
+ source = wmmixer.patch
+ md5sums = bfb1ded801910dd39e1bb0b273c4e1c3
+ md5sums = 2b79b2be0ae022b0dd68ea966b28e65b
pkgname = wmmixer
diff --git a/PKGBUILD b/PKGBUILD
index 87b1fd713eeb..d545c7a97980 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,22 @@
# Maintainer: Brian Bidulock <bidulock@openss7.org>
pkgname=wmmixer
-pkgver=1.7+20141005
+pkgver=1.5
pkgrel=1
pkgdesc="A mixer application written for the WindowMaker dock."
arch=('i686' 'x86_64')
-url="http://windowmaker.org/dockapps/?name=$pkgname"
+url="http://dockapps.windowmaker.org/file.php/id/101"
license=('GPL')
-depends=('libxpm')
-source=("$pkgname-$pkgver.tar.gz::http://windowmaker.org/dockapps/?download=$pkgname-$pkgver.tar.gz")
-md5sums=('SKIP')
+source=("http://linux-bsd-unix.strefa.pl/${pkgname}-${pkgver}.tar.gz" "wmmixer.patch")
+source=("${pkgname}-${pkgver}.tar.gz" "wmmixer.patch")
+md5sums=('bfb1ded801910dd39e1bb0b273c4e1c3'
+ '2b79b2be0ae022b0dd68ea966b28e65b')
build() {
- cd "$srcdir"/dockapps-*
+ cd "${srcdir}/${pkgname}-${pkgver}"
make prefix=/usr
}
-
package() {
- cd "$srcdir"/dockapps-*
+ cd "${srcdir}/${pkgname}-${pkgver}"
make prefix=/usr DESTDIR="$pkgdir" install
}
diff --git a/wmmixer-1.5.tar.gz b/wmmixer-1.5.tar.gz
new file mode 100644
index 000000000000..1a177168dc0b
--- /dev/null
+++ b/wmmixer-1.5.tar.gz
Binary files differ
diff --git a/wmmixer.patch b/wmmixer.patch
new file mode 100644
index 000000000000..d17d7441db15
--- /dev/null
+++ b/wmmixer.patch
@@ -0,0 +1,74 @@
+diff -pur wmmixer-1.5.orig/exception.h wmmixer-1.5/exception.h
+--- wmmixer-1.5.orig/exception.h 2002-06-25 13:22:20.000000000 -0600
++++ wmmixer-1.5/exception.h 2013-03-26 03:39:29.000000000 -0600
+@@ -37,4 +37,4 @@ class MixerDeviceException : public Exce
+ // virtual ~MixerDeviceException();
+ };
+
+-#endif _exception_h__
++#endif // _exception_h__
+diff -pur wmmixer-1.5.orig/mixctl.cc wmmixer-1.5/mixctl.cc
+--- wmmixer-1.5.orig/mixctl.cc 2002-06-25 13:44:55.000000000 -0600
++++ wmmixer-1.5/mixctl.cc 2013-03-26 03:40:28.000000000 -0600
+@@ -243,16 +243,16 @@ char* MixCtl::getLabel(int dev)
+ //----------------------------------------------------------------------
+ bool MixCtl::hasChanged()
+ {
+- struct mixer_info mixer_info;
+- ioctl(mixfd, SOUND_MIXER_INFO, &mixer_info);
++ struct mixer_info mixer_info1;
++ ioctl(mixfd, SOUND_MIXER_INFO, &mixer_info1);
+
+- if (mixer_info.modify_counter == modify_counter)
++ if (mixer_info1.modify_counter == modify_counter)
+ {
+ return false;
+ }
+ else
+ {
+- modify_counter = mixer_info.modify_counter;
++ modify_counter = mixer_info1.modify_counter;
+ return true;
+ }
+ }
+diff -pur wmmixer-1.5.orig/mixctl.h wmmixer-1.5/mixctl.h
+--- wmmixer-1.5.orig/mixctl.h 2002-06-25 14:13:30.000000000 -0600
++++ wmmixer-1.5/mixctl.h 2013-03-26 03:41:23.000000000 -0600
+@@ -23,8 +23,8 @@
+ #ifdef __NetBSD__
+ #include <soundcard.h>
+ #endif
+-#ifdef __FreeBSD__
+-#include <machine/soundcard.h>
++#if defined (__FreeBSD__) || defined(__FreeBSD_kernel__)
++#include <sys/soundcard.h>
+ #endif
+ #ifdef __linux__
+ #include <linux/soundcard.h>
+diff -pur wmmixer-1.5.orig/README wmmixer-1.5/README
+--- wmmixer-1.5.orig/README 2002-06-25 14:20:09.000000000 -0600
++++ wmmixer-1.5/README 2013-03-26 03:41:47.000000000 -0600
+@@ -82,10 +82,10 @@ The effect this has is to enable shape s
+ to reduce the size of the window to 56x56 pixels.
+ The "-position position" option has also been added, so you can push
+ wmcdplay off the edge of the screen while it gets swallowed.
+-To put wmmount in your Wharf, add the following line in the appropriate
++To put wmmixer in your Wharf, add the following line in the appropriate
+ part of your .steprc
+
+-*Wharf wmmixer nil MaxSwallow "wmmount" wmmixer -a -g -0-0 &
++*Wharf wmmixer nil MaxSwallow "wmmixer" wmmixer -a -g -0-0 &
+
+ It is also possible (by editing and recompiling the afterstep sources),
+ to make Wharf handle the new 56x56 pixel window properly - yes, I add
+diff -pur wmmixer-1.5.orig/xhandler.cc wmmixer-1.5/xhandler.cc
+--- wmmixer-1.5.orig/xhandler.cc 2002-06-25 14:13:40.000000000 -0600
++++ wmmixer-1.5/xhandler.cc 2013-03-26 03:39:02.000000000 -0600
+@@ -24,6 +24,7 @@ XHandler::XHandler()
+ strcpy(backcolor_name_, BACKCOLOR);
+
+ button_state_ = 0;
++ icon_list_ = NULL;
+ }
+
+ //--------------------------------------------------------------------