summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFilip Parag2023-08-18 13:24:08 +0200
committerFilip Parag2023-08-18 13:24:35 +0200
commitff31f9ca1546c84e838cdf6acfa07d488ffe25ba (patch)
tree043b85db3cee0b476d7a0d54aa4826efaedc128e
parent7838b86973a5f0cee3d44d4f7caa3fda3a2638ed (diff)
downloadaur-ff31f9ca1546c84e838cdf6acfa07d488ffe25ba.tar.gz
version 2.0.0
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD30
2 files changed, 18 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e64a46d54d14..ff4aab0870ee 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,12 @@
pkgbase = wmrc
- pkgdesc = WMRC is a shell utility for extending window manager capabilities using modules with dependency and error checking.
- pkgver = 1.1
- pkgrel = 6
+ pkgdesc = Simple modular window manager extensions
+ pkgver = 2.0.0
+ pkgrel = 1
url = https://github.com/filiparag/wmrc
arch = any
license = MIT
- depends = dash
- source = wmrc-1.1.tar.gz::https://github.com/filiparag/wmrc/archive/1.1.tar.gz
- sha256sums = ee6bfdac42cc5d7e30e7af593ada869ce71a33a9cb8cc9bcb22040ac044c7bfc
+ depends = coreutils
+ source = wmrc-2.0.0.tar.gz::https://github.com/filiparag/wmrc/archive/2.0.0.tar.gz
+ sha256sums = 57f08ebaa8b937e5253eab7b8be81f4619b652652765c0223978bb7266ac399a
pkgname = wmrc
-
diff --git a/PKGBUILD b/PKGBUILD
index f98d288a51ef..768cf4dbd290 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,21 @@
-# Maintainer: Filip Parag <aur@filiparag.com>
+# Maintainer: Filip Parag <filip@parag.rs>
pkgname=wmrc
-pkgver=1.1
-pkgrel=6
-pkgdesc='WMRC is a shell utility for extending window manager capabilities using modules with dependency and error checking.'
+pkgver=2.0.0
+pkgrel=1
+pkgdesc='Simple modular window manager extensions'
arch=('any')
url='https://github.com/filiparag/wmrc'
license=('MIT')
-depends=('dash')
+depends=('coreutils')
source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
-sha256sums=('ee6bfdac42cc5d7e30e7af593ada869ce71a33a9cb8cc9bcb22040ac044c7bfc')
+sha256sums=('57f08ebaa8b937e5253eab7b8be81f4619b652652765c0223978bb7266ac399a')
package() {
+ cd "${pkgname}-${pkgver}" || return 1
+ install -Dm 775 "./${pkgname}.sh" "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm 664 "./lib${pkgname}.sh" "${pkgdir}/usr/share/${pkgname}/libwmrc.sh"
+ install -Dm 644 "./${pkgname}.man" "${pkgdir}/usr/share/man/man1/${pkgname}.1"
+ sed -i "s/^WMRC_DIR=.*$/WMRC_DIR=\/usr\/share\/${pkgname}/" "${pkgdir}/usr/bin/${pkgname}"
- cd "${pkgname}-${pkgver}"
-
- install -Dm 755 -t "${pkgdir}/usr/bin/" "${pkgname}"
-
- install -Dm 644 'wmrc.man' "${pkgdir}/usr/share/man/man1/${pkgname}.1"
- install -Dm 644 -t "${pkgdir}/usr/share/licenses/${pkgname}" 'LICENSE'
- install -Dm 644 -t "${pkgdir}/usr/share/doc/${pkgname}" 'README.md'
-
- install -Dm 644 -t "${pkgdir}/usr/share/${pkgname}" 'rc.conf' 'usage.txt'
- cp -r --preserve=mode "modules" "${pkgdir}/usr/share/${pkgname}/"
-
-} \ No newline at end of file
+}