summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWeitian Leung2020-01-06 21:47:09 +0800
committerWeitian Leung2020-01-06 21:47:09 +0800
commit59836097e7d418304acbddb575e0a19464982bac (patch)
treedbbc4aecae63872cd8cd15f237efde477b9de82f
downloadaur-59836097e7d418304acbddb575e0a19464982bac.tar.gz
first commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD33
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..406fd9767f9f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = wms-git
+ pkgdesc = A tool for changing WPS Office language with online languages supports.
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/timxx/wms
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = cmake
+ makedepends = qt5-tools
+ depends = qt5-base
+ depends = desktop-file-utils
+ depends = p7zip
+ depends = polkit
+ source = wms-git::git+https://github.com/timxx/wms.git
+ sha256sums = SKIP
+
+pkgname = wms-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..42b4cd1efcb6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Weitian Leung <weitianleung[at]gmail[dot]com>
+
+pkgname=wms-git
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="A tool for changing WPS Office language with online languages supports."
+url="https://github.com/timxx/wms"
+arch=('i686' 'x86_64')
+license=('MIT')
+depends=('qt5-base' 'desktop-file-utils' 'p7zip' 'polkit')
+makedepends=('cmake' 'qt5-tools')
+source=("$pkgname::git+https://github.com/timxx/wms.git")
+sha256sums=('SKIP')
+
+prepare() {
+ mkdir -p "${srcdir}/build"
+}
+
+build() {
+ cd "${srcdir}/build"
+
+ cmake -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ "${srcdir}/${pkgname}"
+
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+
+ make DESTDIR="${pkgdir}" install
+}