summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2015-06-10 23:08:33 -0600
committerBrian Bidulock2015-06-10 23:08:33 -0600
commit574e808c3c22fa35ecf6a0543c8ce50d4149ec5b (patch)
tree2bb9a28d0e950ab3f34713a7daaec49f31432c2d
downloadaur-574e808c3c22fa35ecf6a0543c8ce50d4149ec5b.tar.gz
initial version
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD31
-rw-r--r--wmsmixer-0.5.1.tar.gzbin0 -> 33085 bytes
-rw-r--r--wmsmixer.patch14
4 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f8cb083a187f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = wmsmixer
+ pkgdesc = a hack to wmmixer which makes some changes to the display
+ pkgver = 0.5.1
+ pkgrel = 4
+ url = http://web.archive.org/web/20121021072220/http://dockapps.windowmaker.org/file.php/id/63
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = imake
+ depends = libxpm
+ source = wmsmixer-0.5.1.tar.gz
+ source = wmsmixer.patch
+ md5sums = 02ba412c97c7cc3365690fe74c99f145
+ md5sums = ebaa6d3394ec845d2c8a2c41cb295d56
+
+pkgname = wmsmixer
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..27da639cdc69
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Brian Bidulock <bidulock@openss7.org>
+# Contributer: dedhart [dedinvegas@yahoo.com]
+
+pkgname=wmsmixer
+pkgver=0.5.1
+pkgrel=4
+pkgdesc="a hack to wmmixer which makes some changes to the display"
+arch=('i686' 'x86_64')
+#url="http://dockapps.windowmaker.org/file.php/id/63"
+url="http://web.archive.org/web/20121021072220/http://dockapps.windowmaker.org/file.php/id/63"
+license=('GPL')
+depends=('libxpm')
+makedepends=('imake')
+#source=("http://dockapps.windowmaker.org/download.php/id/268/${pkgname}-${pkgver}.tar.gz"
+# "wmsmixer.patch")
+source=("${pkgname}-${pkgver}.tar.gz"
+ "wmsmixer.patch")
+md5sums=('02ba412c97c7cc3365690fe74c99f145')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ patch -p1 <"${srcdir}/${pkgname}.patch"
+ xmkmf -a
+ make wmsmixer
+}
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+}
+md5sums=('02ba412c97c7cc3365690fe74c99f145'
+ 'ebaa6d3394ec845d2c8a2c41cb295d56')
diff --git a/wmsmixer-0.5.1.tar.gz b/wmsmixer-0.5.1.tar.gz
new file mode 100644
index 000000000000..ced708a6cc6d
--- /dev/null
+++ b/wmsmixer-0.5.1.tar.gz
Binary files differ
diff --git a/wmsmixer.patch b/wmsmixer.patch
new file mode 100644
index 000000000000..acdd2be986f6
--- /dev/null
+++ b/wmsmixer.patch
@@ -0,0 +1,14 @@
+diff -pur wmsmixer-0.5.1.orig/Imakefile wmsmixer-0.5.1/Imakefile
+--- wmsmixer-0.5.1.orig/Imakefile 2003-04-12 16:08:16.000000000 -0600
++++ wmsmixer-0.5.1/Imakefile 2013-03-26 02:12:24.000000000 -0600
+@@ -6,8 +6,8 @@ OSSAUDIO =
+
+ DEPLIBS = $(DEPXLIB)
+ LOCAL_LIBRARIES = $(XPMLIB) $(XLIB) $(OSSAUDIO)
+-CC = c++ -m32
+-LD = c++ -m32 -nostdlib
++CC = c++
++LD = c++ -nostdlib
+
+ SRCS = wmsmixer.cc
+ OBJS = wmsmixer.o